Cannot Upgrade HA From 0.103.0 to 0.103.5

I have Home Assistant installed on a Raspberry PI but attempting to update Home Assistant through the web UI does not work and requires a power cycle in order to access the web UI again. So I tried updating from the CLI but receive this error:

core-ssh:~# hassio homeassistant update
Processing... Done.

Error: Unknown Error, see logs

But I do not see anything in the logs indicating why the update failed:

core-ssh:~# hassio homeassistant logs
2020-01-04 16:03:03 INFO (MainThread) [homeassistant.components.light] Setting up light.zwave
2020-01-04 16:03:03 INFO (MainThread) [homeassistant.setup] Setup of domain automation took 0.0 seconds.
2020-01-04 16:03:03 INFO (MainThread) [homeassistant.setup] Setup of domain hassio took 0.2 seconds.
2020-01-04 16:03:04 INFO (MainThread) [homeassistant.setup] Setup of domain sensor took 1.7 seconds.
2020-01-04 16:03:04 INFO (MainThread) [homeassistant.components.sensor] Setting up sensor.zwave
2020-01-04 16:03:04 INFO (MainThread) [homeassistant.bootstrap] Home Assistant initialized in 11.75s
2020-01-04 16:03:04 INFO (MainThread) [homeassistant.core] Starting Home Assistant
2020-01-04 16:03:04 INFO (MainThread) [homeassistant.components.automation] Initialized trigger Turn Outside Lights Off At Sunrise
2020-01-04 16:03:04 INFO (SyncWorker_19) [homeassistant.components.zwave] Starting Z-Wave network...
2020-01-04 16:03:04 INFO (SyncWorker_19) [openzwave] Start Openzwave network.
2020-01-04 16:03:04 INFO (MainThread) [homeassistant.components.automation] Initialized trigger Turn Outside Lights On At Sunset
2020-01-04 16:03:04 INFO (MainThread) [homeassistant.core] Timer:starting
2020-01-04 16:03:04 INFO (Dummy-2) [openzwave] Driver ready using library Static Controller version Z-Wave 3.95
2020-01-04 16:03:04 INFO (Dummy-2) [openzwave] home_id 0xf72d953d, controller node id is 1
2020-01-04 16:03:13 INFO (SyncWorker_9) [homeassistant.loader] Loaded sonos from homeassistant.components.sonos
2020-01-04 16:03:14 INFO (SyncWorker_18) [homeassistant.loader] Loaded homekit_controller from homeassistant.components.homekit_controller
2020-01-04 16:03:14 INFO (SyncWorker_18) [homeassistant.loader] Loaded neato from homeassistant.components.neato
2020-01-04 16:03:14 INFO (SyncWorker_2) [homeassistant.loader] Loaded zha from homeassistant.components.zha
2020-01-04 16:03:14 INFO (SyncWorker_3) [homeassistant.loader] Loaded logi_circle from homeassistant.components.logi_circle
2020-01-04 16:03:14 INFO (SyncWorker_16) [homeassistant.loader] Loaded luftdaten from homeassistant.components.luftdaten
2020-01-04 16:03:15 INFO (SyncWorker_11) [homeassistant.loader] Loaded ipma from homeassistant.components.ipma
2020-01-04 16:03:15 INFO (SyncWorker_11) [homeassistant.loader] Loaded zone from homeassistant.components.zone
2020-01-04 16:03:15 INFO (SyncWorker_5) [homeassistant.loader] Loaded geonetnz_volcano from homeassistant.components.geonetnz_volcano
2020-01-04 16:03:15 INFO (SyncWorker_19) [homeassistant.loader] Loaded geonetnz_quakes from homeassistant.components.geonetnz_quakes
2020-01-04 16:03:15 INFO (SyncWorker_4) [homeassistant.loader] Loaded tradfri from homeassistant.components.tradfri
2020-01-04 16:03:15 INFO (SyncWorker_6) [homeassistant.loader] Loaded almond from homeassistant.components.almond
2020-01-04 16:03:15 INFO (SyncWorker_13) [homeassistant.loader] Loaded soma from homeassistant.components.soma
2020-01-04 16:03:15 INFO (SyncWorker_13) [homeassistant.loader] Loaded openuv from homeassistant.components.openuv
2020-01-04 16:03:15 INFO (SyncWorker_16) [homeassistant.loader] Loaded cert_expiry from homeassistant.components.cert_expiry
2020-01-04 16:03:15 INFO (SyncWorker_18) [homeassistant.loader] Loaded notion from homeassistant.components.notion
2020-01-04 16:03:15 INFO (SyncWorker_10) [homeassistant.loader] Loaded ambiclimate from homeassistant.components.ambiclimate
2020-01-04 16:03:15 INFO (SyncWorker_11) [homeassistant.loader] Loaded izone from homeassistant.components.izone
2020-01-04 16:03:15 INFO (SyncWorker_5) [homeassistant.loader] Loaded linky from homeassistant.components.linky
2020-01-04 16:03:15 INFO (SyncWorker_8) [homeassistant.loader] Loaded ambient_station from homeassistant.components.ambient_station
2020-01-04 16:03:15 INFO (SyncWorker_4) [homeassistant.loader] Loaded transmission from homeassistant.components.transmission
2020-01-04 16:03:15 INFO (SyncWorker_6) [homeassistant.loader] Loaded upnp from homeassistant.components.upnp
2020-01-04 16:03:15 INFO (SyncWorker_9) [homeassistant.loader] Loaded life360 from homeassistant.components.life360
2020-01-04 16:03:15 INFO (SyncWorker_7) [homeassistant.loader] Loaded lifx from homeassistant.components.lifx
2020-01-04 16:03:15 INFO (SyncWorker_12) [homeassistant.loader] Loaded mailgun from homeassistant.components.mailgun
2020-01-04 16:03:15 INFO (SyncWorker_14) [homeassistant.loader] Loaded locative from homeassistant.components.locative
2020-01-04 16:03:15 INFO (SyncWorker_15) [homeassistant.loader] Loaded plex from homeassistant.components.plex
2020-01-04 16:03:15 INFO (SyncWorker_2) [homeassistant.loader] Loaded somfy from homeassistant.components.somfy
2020-01-04 16:03:15 INFO (SyncWorker_0) [homeassistant.loader] Loaded mobile_app from homeassistant.components.mobile_app
2020-01-04 16:03:15 INFO (SyncWorker_8) [homeassistant.loader] Loaded plaato from homeassistant.components.plaato
2020-01-04 16:03:15 INFO (SyncWorker_4) [homeassistant.loader] Loaded simplisafe from homeassistant.components.simplisafe
2020-01-04 16:03:15 INFO (SyncWorker_6) [homeassistant.loader] Loaded dialogflow from homeassistant.components.dialogflow
2020-01-04 16:03:15 INFO (SyncWorker_9) [homeassistant.loader] Loaded deconz from homeassistant.components.deconz
2020-01-04 16:03:15 INFO (SyncWorker_7) [homeassistant.loader] Loaded iqvia from homeassistant.components.iqvia
2020-01-04 16:03:15 INFO (SyncWorker_12) [homeassistant.loader] Loaded hangouts from homeassistant.components.hangouts
2020-01-04 16:03:15 INFO (SyncWorker_14) [homeassistant.loader] Loaded gpslogger from homeassistant.components.gpslogger
2020-01-04 16:03:15 INFO (SyncWorker_15) [homeassistant.loader] Loaded traccar from homeassistant.components.traccar
2020-01-04 16:03:15 INFO (SyncWorker_2) [homeassistant.loader] Loaded ios from homeassistant.components.ios
2020-01-04 16:03:15 INFO (SyncWorker_0) [homeassistant.loader] Loaded opentherm_gw from homeassistant.components.opentherm_gw
2020-01-04 16:03:15 INFO (SyncWorker_8) [homeassistant.loader] Loaded iaqualink from homeassistant.components.iaqualink
2020-01-04 16:03:15 INFO (SyncWorker_4) [homeassistant.loader] Loaded twilio from homeassistant.components.twilio
2020-01-04 16:03:15 INFO (SyncWorker_6) [homeassistant.loader] Loaded homematicip_cloud from homeassistant.components.homematicip_cloud
2020-01-04 16:03:15 INFO (SyncWorker_9) [homeassistant.loader] Loaded solarlog from homeassistant.components.solarlog
2020-01-04 16:03:15 INFO (SyncWorker_7) [homeassistant.loader] Loaded solaredge from homeassistant.components.solaredge
2020-01-04 16:03:15 INFO (SyncWorker_12) [homeassistant.loader] Loaded ps4 from homeassistant.components.ps4
2020-01-04 16:03:15 INFO (SyncWorker_14) [homeassistant.loader] Loaded rainmachine from homeassistant.components.rainmachine
2020-01-04 16:03:16 INFO (SyncWorker_15) [homeassistant.loader] Loaded ifttt from homeassistant.components.ifttt
2020-01-04 16:03:16 INFO (SyncWorker_2) [homeassistant.loader] Loaded met from homeassistant.components.met
2020-01-04 16:03:16 INFO (SyncWorker_0) [homeassistant.loader] Loaded glances from homeassistant.components.glances
2020-01-04 16:03:16 INFO (SyncWorker_8) [homeassistant.loader] Loaded wemo from homeassistant.components.wemo
2020-01-04 16:03:16 INFO (SyncWorker_4) [homeassistant.loader] Loaded abode from homeassistant.components.abode
2020-01-04 16:03:16 INFO (SyncWorker_6) [homeassistant.loader] Loaded wwlln from homeassistant.components.wwlln
2020-01-04 16:03:16 INFO (SyncWorker_9) [homeassistant.loader] Loaded emulated_roku from homeassistant.components.emulated_roku
2020-01-04 16:03:16 INFO (SyncWorker_7) [homeassistant.loader] Loaded wled from homeassistant.components.wled
2020-01-04 16:03:16 INFO (SyncWorker_12) [homeassistant.loader] Loaded coolmaster from homeassistant.components.coolmaster
2020-01-04 16:03:16 INFO (SyncWorker_14) [homeassistant.loader] Loaded daikin from homeassistant.components.daikin
2020-01-04 16:03:16 INFO (SyncWorker_15) [homeassistant.loader] Loaded point from homeassistant.components.point
2020-01-04 16:03:16 INFO (SyncWorker_2) [homeassistant.loader] Loaded twentemilieu from homeassistant.components.twentemilieu
2020-01-04 16:03:16 INFO (SyncWorker_0) [homeassistant.loader] Loaded heos from homeassistant.components.heos
2020-01-04 16:03:16 INFO (SyncWorker_8) [homeassistant.loader] Loaded mqtt from homeassistant.components.mqtt
2020-01-04 16:03:16 INFO (SyncWorker_4) [homeassistant.loader] Loaded hue from homeassistant.components.hue
2020-01-04 16:03:16 INFO (SyncWorker_6) [homeassistant.loader] Loaded cast from homeassistant.components.cast
2020-01-04 16:03:16 INFO (SyncWorker_9) [homeassistant.loader] Loaded nest from homeassistant.components.nest
2020-01-04 16:03:16 INFO (SyncWorker_7) [homeassistant.loader] Loaded axis from homeassistant.components.axis
2020-01-04 16:03:16 INFO (SyncWorker_12) [homeassistant.loader] Loaded ecobee from homeassistant.components.ecobee
2020-01-04 16:03:16 INFO (SyncWorker_14) [homeassistant.loader] Loaded starline from homeassistant.components.starline
2020-01-04 16:03:16 INFO (SyncWorker_17) [homeassistant.loader] Loaded adguard from homeassistant.components.adguard
2020-01-04 16:03:16 INFO (SyncWorker_2) [homeassistant.loader] Loaded tellduslive from homeassistant.components.tellduslive
2020-01-04 16:03:16 INFO (SyncWorker_0) [homeassistant.loader] Loaded geofency from homeassistant.components.geofency
2020-01-04 16:03:16 INFO (SyncWorker_8) [homeassistant.loader] Loaded huawei_lte from homeassistant.components.huawei_lte
2020-01-04 16:03:16 INFO (SyncWorker_4) [homeassistant.loader] Loaded withings from homeassistant.components.withings
2020-01-04 16:03:16 INFO (SyncWorker_6) [homeassistant.loader] Loaded velbus from homeassistant.components.velbus
2020-01-04 16:03:16 INFO (SyncWorker_9) [homeassistant.loader] Loaded toon from homeassistant.components.toon
2020-01-04 16:03:16 INFO (SyncWorker_7) [homeassistant.loader] Loaded unifi from homeassistant.components.unifi
2020-01-04 16:03:16 INFO (SyncWorker_12) [homeassistant.loader] Loaded esphome from homeassistant.components.esphome
2020-01-04 16:03:16 INFO (SyncWorker_14) [homeassistant.loader] Loaded airly from homeassistant.components.airly
2020-01-04 16:03:16 INFO (SyncWorker_17) [homeassistant.loader] Loaded smartthings from homeassistant.components.smartthings
2020-01-04 16:03:16 INFO (SyncWorker_2) [homeassistant.loader] Loaded smhi from homeassistant.components.smhi
2020-01-04 16:03:16 INFO (SyncWorker_0) [homeassistant.loader] Loaded vesync from homeassistant.components.vesync
2020-01-04 16:03:16 INFO (SyncWorker_8) [homeassistant.loader] Loaded owntracks from homeassistant.components.owntracks
2020-01-04 16:03:16 INFO (SyncWorker_4) [homeassistant.loader] Loaded tplink from homeassistant.components.tplink
2020-01-04 16:03:16 INFO (SyncWorker_6) [homeassistant.loader] Loaded hisense_aehw4a1 from homeassistant.components.hisense_aehw4a1
2020-01-04 16:07:25 INFO (Dummy-2) [homeassistant.components.zwave] Z-Wave network is complete. All nodes on the network have been queried, but some nodes are marked dead
2020-01-04 16:07:26 INFO (MainThread) [homeassistant.components.zwave] Z-Wave ready after 261 seconds
2020-01-04 16:07:26 INFO (SyncWorker_12) [homeassistant.components.zwave] Z-Wave polling interval set to 60000 ms

It appears that I have plenty of space on my SD card (except I’m not sure about /dev/init):

core-ssh:~# df -h
Filesystem                Size      Used Available Use% Mounted on
overlay                  28.4G      3.8G     23.1G  14% /
tmpfs                    64.0M         0     64.0M   0% /dev
tmpfs                   463.1M         0    463.1M   0% /sys/fs/cgroup
/dev/root                90.3M     90.3M         0 100% /dev/init
/dev/mmcblk0p8           28.4G      3.8G     23.1G  14% /addons
/dev/mmcblk0p8           28.4G      3.8G     23.1G  14% /backup
/dev/mmcblk0p8           28.4G      3.8G     23.1G  14% /share
/dev/mmcblk0p8           28.4G      3.8G     23.1G  14% /data
/dev/mmcblk0p8           28.4G      3.8G     23.1G  14% /config
/dev/mmcblk0p8           28.4G      3.8G     23.1G  14% /ssl
/dev/mmcblk0p8           28.4G      3.8G     23.1G  14% /etc/resolv.conf
/dev/mmcblk0p8           28.4G      3.8G     23.1G  14% /etc/hostname
/dev/mmcblk0p8           28.4G      3.8G     23.1G  14% /etc/hosts
shm                      64.0M         0     64.0M   0% /dev/shm
tmpfs                    64.0M         0     64.0M   0% /proc/keys
tmpfs                    64.0M         0     64.0M   0% /proc/latency_stats
tmpfs                    64.0M         0     64.0M   0% /proc/timer_list
tmpfs                    64.0M         0     64.0M   0% /proc/sched_debug
tmpfs                   463.1M         0    463.1M   0% /sys/firmware

Another thing, the IP address of my interface does not match what I have set:

core-ssh:~# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
18: [email protected]: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue state UP 
    link/ether 02:42:ac:1e:21:00 brd ff:ff:ff:ff:ff:ff
    inet 172.30.33.0/23 brd 172.30.33.255 scope global eth0
       valid_lft forever preferred_lft forever

I access the web UI using a 192.168.1 network.

Does anyone know what is going on and how I can resolve this issue?

Anyone know why this will not work or other log files I could look at that actually contain the error?

Supervisor logs are what you want to check after it fails. Not the home assistant logs. hassio su logs

Thank you! I had to power cycle the RPi in order to start the SSH server and the . These logs are before I tried to update again through the web UI, so not sure if that matters:

core-ssh:~# hassio su logs
20-01-08 12:37:51 INFO (MainThread) [hassio.host.info] Update local host information
20-01-08 12:37:51 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/hostname1
20-01-08 12:37:52 ERROR (MainThread) [hassio.utils.gdbus] DBus return error: 
20-01-08 12:37:52 WARNING (MainThread) [hassio.host.info] Can't update host system information!
20-01-08 12:37:52 INFO (MainThread) [hassio.host.services] Update service information
20-01-08 12:37:52 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.systemd1.Manager.ListUnits on /org/freedesktop/systemd1
20-01-08 12:37:53 ERROR (MainThread) [hassio.utils.gdbus] DBus return error: 
20-01-08 12:37:53 WARNING (MainThread) [hassio.host.services] Can't update host service information!
20-01-08 12:37:53 INFO (MainThread) [hassio.host.network] Update local network DNS information
20-01-08 12:37:53 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/NetworkManager/DnsManager
20-01-08 12:37:54 ERROR (MainThread) [hassio.utils.gdbus] DBus return error: 
20-01-08 12:37:54 WARNING (MainThread) [hassio.host.network] Can't update host DNS system information!
20-01-08 12:44:31 INFO (MainThread) [hassio.store.git] Update add-on https://github.com/hassio-addons/repository repository
20-01-08 12:44:31 INFO (MainThread) [hassio.store.git] Update add-on https://github.com/home-assistant/hassio-addons repository
20-01-08 12:44:31 INFO (MainThread) [hassio.updater] Fetch update data from https://version.home-assistant.io/stable.json
20-01-08 12:44:32 ERROR (MainThread) [hassio.store.git] Can't update https://github.com/hassio-addons/repository repo: Cmd('git') failed due to: exit code(-11)
  cmdline: git fetch --depth=1 --update-shallow -v origin.
20-01-08 12:44:32 ERROR (MainThread) [hassio.store.git] Can't update https://github.com/home-assistant/hassio-addons repo: Cmd('git') failed due to: exit code(-11)
  cmdline: git fetch --depth=1 --update-shallow -v origin.
20-01-08 12:44:33 INFO (MainThread) [hassio.store] Load add-ons from store: 62 all - 0 new - 0 remove
20-01-08 13:21:38 INFO (MainThread) [hassio.api.security] /supervisor/logs access from core_ssh

I’m not sure about the git error but I did try to address the DNS warning by setting the DNS to my local DNS server:

hassio dns options --servers dns://192.168.1.1

I then rebooted the RPi:

hassio host reboot

Now I’m not able to access the web UI or SSH. Not sure what happened.

I SSH’d into Hass.io and executed:

hassio homeassistant update
Processing... Done.

Error: Unknown Error, see logs

but when checking the supervisor logs I only see this error:

core-ssh:~# hassio su logs

Get http://hassio/supervisor/logs: dial tcp: lookup hassio on [::1]:53: dial udp [::1]:53: connect: cannot assign requested address

I don’t really see how the IPv6 loopback DNS error is causing the issues I’m experiencing as I’m not using IPv6.

One occasion I SSH’d into HassIO and these notifications appeared:

-bash: S:disk/by-id/mmc-NCard_0x260c2a4e: No such file or directory
-bash: S:disk/by-path/platform-3f202000.mmc: No such file or directory
-bash: W:22: command not found
-bash: I:58396840513: command not found
-bash: E:ID_NAME=NCard: command not found
-bash: E:ID_PART_TABLE_TYPE=gpt: command not found
-bash: E:: command not found

I’m wondering if this is a bad SD card?