Cannot upgrade to HassOS 3.9

Tags: #<Tag:0x00007f77fb291a10>

I cannot upgrade to HassOS 3.9 from 3.8. I get the following error messages. Any ideas?

20-02-07 01:34:38 INFO (MainThread) [hassio.core] Hass.io is up and running
20-02-07 01:34:54 INFO (MainThread) [hassio.hassos] Fetch OTA update from https://github.com/home-assistant/hassos/releases/download/3.9/hassos_ova-3.9.raucb
20-02-07 01:34:57 INFO (MainThread) [hassio.hassos] OTA update is downloaded on /data/tmp/hassos-3.9.raucb
20-02-07 01:34:57 INFO (MainThread) [hassio.utils.gdbus] Call de.pengutronix.rauc.Installer.Install on /
20-02-07 01:34:57 INFO (MainThread) [hassio.utils.gdbus] Start dbus monitor on de.pengutronix.rauc
20-02-07 01:34:57 INFO (MainThread) [hassio.utils.gdbus] Stop dbus monitor on de.pengutronix.rauc
20-02-07 01:34:57 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /
20-02-07 01:34:57 ERROR (MainThread) [hassio.hassos] HassOS update fails with: Failed mounting bundle: failed to run mount: Child process exited with code 32

2 Likes

same issue here

If you guys have access to the terminal and CLI, you can run in there: hassio host update. I got the same problem a couple of times (even running through command line) until it got updated after running the command 3 or 4 times.

1 Like

Please add a comment here to increase visibility: https://github.com/home-assistant/operating-system/issues/544

1 Like

The CLI worked for me, but the command was: hassio hassos update

2 Likes

Neither CLI nor the admin interface works for me.
Any suggestions ?

Running Oracle Virtual Box on Dell Laptop. Renamed Hostname to homeassistant and rebooted. Still getting Child process exited with code 32. After several times of exiting Supervisor and trying to Update it finally updated.

I’m trying to go from HassOS 3.5 to 3.11. I have tried the following command from the CLI:
“ha os update”, but the error I get is “loop0 () has still dirty pages (nrpages=xx)”

This is with virtual machine where the original image used was the vmdk image. I already had to expand one of the partitions to allow the HA Core updates, so I’m wondering if I need to do the same to get the OS to upgrade.

In the worst case, I guess I can make a backup of the configuration, install the newest vmdk image, then restore the configuration backup.

1 Like

Worked for me, thx.

1 Like