Can't access from remote with DuckDNS + NGINX

i’m trying to get access from remote with my Home Assistant OS installed in RPi3. I installed DuckDNS and NGINX using this guide. I configured the acces of Google Home following a youtube guide, and it works fine.
If i’m connected to my wifi network and i go to i can access to my home assistant. However, if i try to access with 4G connection, so without my wifi network, i see only a white page with “Initialization” write.
This is strange because Google Home can communicate to HA, but i can’t. Do you know the origin of the problem?
Thank you,

I wrote a guide a few days ago. Take a look at that and see if you followed the same steps.

Ok, i’m trying to following your guide. I succesfully installed MariaDB and Frenk NGINX Add-on. Now the situation is like before. In your guide you say

I then had to go to Google console and update the address it uses to send commands to ha. Just had to remove :8123 from the middle of the URL.

but i have no :8123 in the URL. I followed this guide to integrate Google Home.

Ok, you’re ok there then, I previously wasn’t using nginx so needed to update that.
Have you forwarded the necessary ports in your router / firewall to nginx?

Have you got a screenshot of the initialising page?

I forwarded TCP 80, 81 and 443 ports. I noticed something strange. As i said, if i try to access from my phone via LTE 4G it returns the following page

But if i create an hotspot and i access with my computer through my mobile network it works. It’s really strange!
However i need to access with my phone through the mobile app.

So that screenshot is from the mobile app?
What do you get if you enter the duckdns address from the mobile browser rather than the companion app?

This is the screenshot from the mobile browser of my smatphone, the companion app returns error.
I noticed that the problem comes from my telephone operator Vodafone (I don’t know if you have it in your contry). In fact i tried to acces from my parents smarthpones (which have another operator) and it works both with the companion app and the mobile browser. Moreover, if i connect to their hotspot i can access to HA also with my smartphone. Then, i tried to access from my girlfriend’s smartphone, which has the same operator Vodafone, and she too can’t connect to HA. I think now you can’t help me (i hope you can) because i need to search why there is this conflict with my telephone operator. Thank you so much for your attention.

We have Vodafone here, but unfortunately (or fortunately) don’t use it so can’t test for you.
It may be they don’t like duckdns. Is there a content filter on he account you can turn off?
If you open a VPN app can you connect?