Cant access HA from debian

Good afternoon!

Not sure if this is the right place to post, been googling for a while and can’t seem to figure out my issue, I have HA up and running for about a month now, I just installed Debian on an orange pi I grabbed for the wife, she wanted a smart calendar/chore list for the kitchen, figured I should be able to use the browser on the Opi to just open a web interface to HA and lock it to a dashboard I built just for the calendar.
For some reason no matter what I do, when I open the browser on the Opi and try to navigate to homeassistant.local or homeassistant.local:8123 it just times out, yes it’s on the same network as my HA machine, tried droid OS on the Opi too and same issue.

Any ideas? I feel like I just have to be missing somthing super basic here!


Try xx.xx.xx.xx:8123, where xx.xx.xx.xx is the IP address of HA

Yeah I did that too, the real ip of the HA and still times out, but does it instantly instead of sitting and trying for a while, I tried with the real ip on other devices and it takes me to HA dashboard instantly

Check to see if the firewall is enable on Debian, try to disable and test if it’s blocking it.

Hadn’t thought of that, I’ll try when I get home from work, thanks for the idea!

Did it get an ip from your router?
(apparently yes)
Can you ping the router?
Can you open other internet pages?

yes I have the IP
I can ping the router and it responds (i can actually log into the router settings page from the orangepi)
I can go to many other internet pages, just not HA dashboard/UI

So I got it to work, default line was HTTPS:// I removed the S and then typed the IP:8123 and it worked, not sure why the S was stopping me

thanks for all the suggestions!