Can't access HA UI on Firefox after core update

Updated last night through UI. Left it and went to bed while it was still running.

This morning, I can’t access the UI with Firefox on my desktop through network using https://homeassistant.local:8123 or But I CAN access UI on using chrome and or https://homeassistant.local:8123.
Have tried clearing cache and cookies, dns flush, router reboot.

Any ideas on how to get Firefox to play ball?

I use Firefox with no issues. Try disabling your Firefox extensions and see if you can get to HA. Then turn them back on one-by-one until you find the one that is causing problems. If I had to guess, it’s probably an extension that has to do with privacy or security.

Did you forget to mentions reboot of your device , or just “flushed” them … just wondering
I have also updated 2 of my Ha-instances ( different configurations, different hosts, thou both Homeassistant OS " In VMware , 1 in Windows10, other in Debian12" )
Viewing from same device(laptop), no issues in either FF or Edge, i never use Chrome thou

PS: And i didn’t reboot neither my laptop or HA’s, all went smooth here
It was however an OS update, so you could first try to do an additional reboot of your HA, and as you seems to use SSL somehow, then read the release-note to check whether there is somethings that could affect your specific installation

Found it in the end - A while ago I tried to set up my HA so that I could access it remotely.
This involved adding DuckDNS (which includes LetsEncrypt) and adding a couple of lines to my HA config file to send traffic through https://. This was never a problem in the past accessing HA locally with Firefox - you just ignored the “insecure site” warning / accepted the risk and it was fine. - this is what I can still do with chrome. But it seems now that FF doesn’t give you the option to do this - even by changing security settings. It just doesn’t let you visit the “insecure” site. My guess is that I recently had a FF update to the new version with this restriction, but remained logged in to HA, so it wasn’t an issue. Only when the core update logged me out did accessing the UI become an issue.
When they finally get round to installing fibre broadband here and I can set HA up for remote access I’ll have to revisit this. I think there may be a way around it with NGINX, but I’ll work that one out when I have to…

1 Like