Can't access after installing DuckDNS

trying to access after installing Duckdns, but i can’t.

What i did:

  1. created a DuckDns account
  2. activated the DuckDNS addon through the (and edited the config)
  3. edited configuration.yaml with:
    ssl_certificate: /ssl/fullchain.pem
    ssl_key: /ssl/privkey.pem
  4. forwarded port 8123 to the ip address of the raspberry pi.

I can reach the raspberry pi through samba, but i can’t get through browser. I don’t have ssh installed.

remove the “:8123” from your base url.

Thanks for helping! That didn’t solve the problem…

Should i access within my network through ip or DuckDns address?

That depends wether your router/modem supports nat loopback.

First thing to do is add https:// in front of your ip address.
go https://internal.ip.addres:port
That should help us make sure that everythning is working ok

(If that doesnt work, try pinging the device, to see if it responds)

Second, use your mobile phone (with 3g data) or have a friend outside your lan hit up your duckdns address again with httpS and see if everything works

Then if both the above work, you have several choices.

  1. Access hassio from the internal ip address whenever you are home and the external whenever you are out.
  2. Check if your modem supports NAT loopback (which will translate the external ip addres into internal) so you can access hassio from the same shrotcut where ever you are.
  3. Other workarounds, like getting another modem, using a DNSmasq (or pihole) addon on hassio which will do what your router couldnt or edit the hosts file on your pc accordingly

Let us know if the httpS thingy worked and we ll see how we go on from there

Also, in contrast to what @dap35 suggested, my configuration includes the port number:

  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

Wow, thanks! Here the results:

  • no reponse through browser with httpS
  • Ping returns answers (i can access the shares through samba)
  • yes, it supports nat loopback
  • tried to access it from outside the network (i have rdp setup to my office)… no reponse :frowning:

A had similar case. The issue was on second firewall from my providers side. So there was firewall on router (443 was opened by mapping to 8123), but firewall from router was enabled and all ports were closed. That was pretty strange…

Did you try both the ip and the duckdns name with https from your network?

Also since samba works, have look at homeassistant.log for some clues…

Ofcourse! How could i forget that :slight_smile: (thanks for reminding me :slight_smile: )

The log points to configuration.yaml:
2018-12-05 21:57:23 ERROR (SyncWorker_0) [homeassistant.util.yaml] while scanning a simple key
in “/config/configuration.yaml”, line 106, column 1
could not find expected ‘:’
in “/config/configuration.yaml”, line 107, column 3
2018-12-05 21:57:23 ERROR (MainThread) [homeassistant.bootstrap] Error loading /config/configuration.yaml: while scanning a simple key
in “/config/configuration.yaml”, line 106, column 1
could not find expected ‘:’
in “/config/configuration.yaml”, line 107, column 3

Here’s the content of that part (from line 106):

  "lets_encrypt": {
    "accept_terms": true,
    "certfile": "fullchain.pem",
    "keyfile": "privkey.pem"
  "token": "yes-my-own-key",
  "domains": [""],
  "seconds": 300

What did i do wrong?

Try resetting it to the default values, here they are from the addon:

  "lets_encrypt": {
    "accept_terms": false,
    "certfile": "fullchain.pem",
    "keyfile": "privkey.pem"
  "token": null,
  "domains": [
  "seconds": 300

Other than that it looks same as mine, try rewriting it in case something’s wrong in the code.

Also, why is that part inside your configuration.yaml? Mine does not show up there normally.
(perhaps its because of the error?)

Well that helped… interface is back :slight_smile:

But SSL isn’t working. Error logs says:

Error doing job: SSL error errno:1 reason: HTTP_REQUEST
Traceback (most recent call last):
File “uvloop/sslproto.pyx”, line 504, in uvloop.loop.SSLProtocol.data_received
File “uvloop/sslproto.pyx”, line 204, in uvloop.loop._SSLPipe.feed_ssldata
File “uvloop/sslproto.pyx”, line 171, in uvloop.loop._SSLPipe.feed_ssldata
File “/usr/local/lib/python3.6/”, line 689, in do_handshake
ssl.SSLError: [SSL: HTTP_REQUEST] http request (_ssl.c:841)

I’d Uninstall the component, restart hassio, check for errors in the log, then try redoing everything step by step.

My vote for the community award 2018! :slight_smile: I got it working again. Unless, the certificate isn’t recognised. Will post that in a different thread.

1 Like