Can't access Home Assistant via extended WiFi network

Tags: #<Tag:0x00007f3267f27510>

Hi, I’d like to ask for help figuring out the following problem. Please see my setup (roughly) in the above image. I can access hassio via web/app when on main Router’s WiFi network, any other WiFi network, or on Cellular connection, but not when on WiFi Extender’s WiFi network. The extender (TP Link RE650) doesn’t have its own DHCP or port forwarding options and acts as a slave to Router’s settings.

Hope I haven’t missed out on any relevant detail, but please let me know if I have.

What I’ve tried:

  • Setting up DMZ on either Hassio’s static IP or WiFi Extender’s static IP
  • Setting up 8123 > 8123 port forwarding for WiFi Extender’s static IP
  • Moving Hassio from wired to wireless connection to the WiFi extender
  • Factory resetting the WiFi extender

Neither of the above options have helped. Would really appreciate your suggestions!

Thanks :slight_smile:

Is the ssid of the extender “bridged” to your initial ssid? It needs to be in your setup.

To be honest i don’t entirely understand the slave / dmz thing you describe. (I am just a developer with basic network knowledge)

Is it just a regular repeater that extends the range of the existing wifi netowrk?
I am using such a device as well but in my case i have the lan port of the extender connected to the source network.
All devices connected to the extender are in the regular network and use the dns server of the router.
If you connect the PI to the Wifi-Extender you might create a entirely seperated network, what could be the reason why it does not work.

But on connection issues my first step usually is to find out if it is a connection or a dns problem.
Can you access the pi by ip instead of network name? Furthermore you can try to get in depth with the tools tracert, ping and telnet

Hopefully this more generic tips can help you.

HI.

AFAIK a Wifi extender is doing what the name says - it extend the wifi. I’m not sure what you mean with “access from wifi extender network”, as you pi is connected by cable to the wifi extender.
Also the duckDNS should be on the left side of the drawing or do you bypass your router etc using a 4G/public Wifi card on the PI4?
I remember that these Wifi extender devices do have several options…
a) Acting as Wifi router, means that the RJ45 socket is for the connection to the outer world
b) Acting a Cabled Wifi extender (simple Access Point), where the RJ45 is used as connection to the normal network (in this case this cable should not be in the PI4, it should be on the router)
c) Acting as Wifi extender, in this case the antennas will simply connect to your existing wifi and bridge the RJ45 port to be used by a normal device via cable (maybe your setup, but than you cannot access the “extender wifi” as a seperate one
d…
One thing I can thing about: Some Routers / wifi configurations allow to block connections from one to another WIFI connected device. If this feature is enabled on your setup than that might be reason for your problem…

Just my 2 cents - have a nice day,
Oliver

Hey, I’ve though about too. It’s set to “extend” the host network, so should be fine in that regard.

What’s the ip adress and subnet of your hassio and your device that connects to this 2 ssids? Does the ip stays the same between switching these ssids?

Hi, thanks for sharing your thoughts. It’s a regular repeater indeed, connected to the host network wirelessly and extending that network.

“If you connect the PI to the Wifi-Extender you might create a entirely seperated network, what could be the reason why it does not work.” - that shouldn’t be the case. Hassio’s PI isn’t even seen on the list of extender’s clients, it appears only under the rooter’s client list, where router’s DHCP has a static IP assigned to it.

“Can you access the pi by ip instead of network name?” - no, since setting up DuckDNS, I can only access it via xxxxx.duckdns.org (both when in local network or outside of it), neither addressing it by IP (with or without :8123) or hassio.local (with or without :8123) works.

Just to be clear. You have the issues when connecting to the duckdns name only? Or also internal ip address of your hass? Why would you want to connect to an external duckdns name and “flow” your traffic via thr outside of your Internet router?

Connect your phone or a laptop to your primary network. Write the IP-address down. Now connect the same phone or laptop to your extended wifi. Write the IP-address down. Check if both IP-addresses are in the same range.

Hi, I’d love to connect locally when on local network, but I can’t as local connection no longer works for me since installing DuckDNS.

Just tested this. My IP on Router’s WiFi connection was 192.168.1.146. On WiFi extender’s connection, it was 192.168.1.123. I understand it means it’s the same network, doesn’t it?

Also, in both cases Subnet Mask remained 255.255.255.0, and “Router” value under the WiFi settings stayed 192.168.1.1 (my Router’s IP).

Yes, you stay on the same network. Now I have no clue why it would not work.

What is you hass ip adress?

It’s 192.168.1.165, static

Can you ping it from both?

Hi, yes, I can:

From Router’s WiFi:

PING 192.168.1.165 (192.168.1.165)
44 bytes from 192.168.1.165 : icmp_seq=0 ttl=64 time=173 ms
44 bytes from 192.168.1.165 : icmp_seq=1 ttl=64 time=7 ms
44 bytes from 192.168.1.165 : icmp_seq=2 ttl=64 time=11 ms
44 bytes from 192.168.1.165 : icmp_seq=3 ttl=64 time=28 ms
44 bytes from 192.168.1.165 : icmp_seq=4 ttl=64 time=7 ms
44 bytes from 192.168.1.165 : icmp_seq=5 ttl=64 time=20 ms
--- 192.168.1.165 ping statistics ---
6 packets transmitted, 6 packets received, lost 0.0 %

From extender’s WiFi

PING 192.168.1.165 (192.168.1.165)
44 bytes from 192.168.1.165 : icmp_seq=0 ttl=64 time=4 ms
44 bytes from 192.168.1.165 : icmp_seq=1 ttl=64 time=8 ms
44 bytes from 192.168.1.165 : icmp_seq=2 ttl=64 time=8 ms
44 bytes from 192.168.1.165 : icmp_seq=3 ttl=64 time=2 ms
44 bytes from 192.168.1.165 : icmp_seq=4 ttl=64 time=1148 ms
--- 192.168.1.165 ping statistics ---
5 packets transmitted, 5 packets received, lost 0.0 %

Testing this out further, I found that I actually CAN access Hassio locally from both networks, but only using https://192.168.1.165:8123 (https + Hassio local IP + port), however that triggers a “This site is not secure, please return to previous website…” warning via web (can be bypassed on web once acknowledged), but not via app (says connection isn’t secure, can be an impostor bla bla). CORRECTION: I can’t via extender’s network. I get a greeting screen prompting to enter username and password for Hassio, but after entering it says “Unable to connect to Home Assistant”.

I’ve also never succeeded to configure Let’s Encrypt for Duck DNS. If I set accept_terms to “true”, the add-on fails to start with the following in logs:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] done.
[services.d] starting services
[services.d] done.
# INFO: Using main config file /data/workdir/config
ERROR: Lock file '/data/workdir/lock' present, aborting.
[cmd] /run.sh exited 1
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

I’m not sure if the two issues are related. It’s still a case that I can’t access xxxx.duckdns.org when connected to the extender’s WiFi.

UPDATE: another symptom of the issue is that when I’m on the extended WiFi, the HomeKit device statuses won’t update (via hassio HomeKit integration), whereas they update without an issue when I’m on the router’s WiFi or outside of the network.

I have the same thing going on if you get it sorted please share
Also stops the app working at home on the ap wifi extension

Hey, I ended up getting rid of DuckDNS and switched to the cloud subscription. Going strong for 2 months now with no access issues from extended network. I know it’s paid but this, as well as other cloud subscription features, have made it worth it.