Cant access homeassistant UI


Followed this official installation guide : HA installation guide to install HA on my RPI 3 model B.

RPI is connected directly to my router via ethernet cable and I validate its IP address after accessed to my router gateway (also pinged it and saw reply).

I’m trying to access it through also tried http://homeassistant.local:8123/ or http://homeassistant:8123/ but nothing came up, just :

Also I see this log :

Any ideas ? what can I do to overcome this issue ?

Thanks in advance

In my opinion, your Raspberry Pi has not finished booting up.

It’s been a while since I’ve used on a Pi, but when the Pi has completed the boot sequence you should be presented by a login prompt.

Actually, I can see that it says:

EXT4-fs error .....

So there is a problem reading from your SD card.

Simple solution is to write the image file to your SD card again and it should work.

Thank you for the reply !

I’ll buy another new SD card because I already flashed it before because of such a login problem so I guess my SD card is corrupted.
Do you have a recommendation for an appropriate one ? will 16GB is enough for HA ?

Yes 16GB should be fine.
Gigabytes aren’t a good metric if you’re having corrupted card issues.

Have a look at class number and the read/write speeds on reviews.

So what class number & read / write speeds should I need to buy for that purpose ?

Application Performance Class 2 (A2), as they handle small I/O much more consistently than cards not optimized to host applications. A 32 GB or bigger card is recommended.

I saw this recommendation but I find either class 4, 3 or 10, nor class 2 at 16GB.

for example :


That’s speed class. My previous post was misleading (sorry), you want to look for “A2” on the product page.

The first amazon link you have shows on the card it’s stamped “A1”.

If you look at this one, you’ll see it has “A2” written on it.

If you look at this wikipedia page, the two tables below my link, you’ll see the speed classes and application classes. The first link you have, the speed class is 10 (in a circle). That means that it’s good for 10 MB/s. The one I linked has a speed class of 3 (inside of a U), which means it’s good for 30 MB/s. It’s a bit confusing, I know.

But there is no 16GB with class 2 , just 64GB and above and a 32 GB or bigger card is recommended.

Does ‘A2’ stamping is really important ?

32GB or larger is recommended, so I would just go for a 64GB one if that’s the smallest you can find.

Yes. An A1 card will work, but is more likely to die early and have other problems.
An A2 type card is able to handle 266% more read IOPS, and (more importantly) 400% more write IOPS. It’s a card type optimized for running applications that have many small I/O operations like HA does.

A 16GB A1 card will work, but why deviate from the recommendation?

Have you reformatted the card and tried again?

Yes, a couple of times.
This time I noticed this log, other times it just didn’t logged in.

Is this good enough ?

the cheapest A2 one I found in a store near my home.

A2 , class 10
Micro SDXC

Didn’t noticed that the recommendation is for a 32GB or bigger (thought no bigger than 32GB, my mistake)

Yes, from what I can tell that card (SDCG3) is plenty fast and rated as A2. Should work well.

Thank you very much

yeah thats fine. However, just make sure, once everymonth, you take keep an image of the entire SD card. So that if it fails, you can just format another one

OK. thanks for the advice

Another question : I’m looking for a safe way to shutdown the RPI ( installed on) other than pulling its power from its power connector. How can I do it ? maybe this what cause my sd card to be corrupted.

Yes, pulling the power on it without properly shutting it down can lead to corruption.

If you have access to the website, if you go to the Supervisor tab, then System, there’s a button to shutdown the host.

If you have SSH access, you can SSH in and execute “ha host shutdown”.

SD card corruption can be fixed with card format and reflashing or once it corrupted an irreversible damage was done ?

Typically a reformat will get it working again, but it depends (the kind of thing you can try out and see how it goes).
I’m not sure if there’s any lasting effect, I don’t think so though.

If it was corrupted by pulling power, then it might be fine for a while longer (assuming you don’t do that again).
If it got corrupted randomly, it’s likely to happen again.