Can't access my home assistant through wifi devices on same local network

Hi
Atm. i’m on my pc with a wired network access to my network and can access my NAS/VM Home Assistant through homeassistant.local:8132 but not on the static IPv4 172.25.xxx.33:8132.

All wired network connections can access my HA, but when i’m using a device through my WiFi, I get a “ERR_CONNECTION_REFUSED” but my phone through the HA app. did see the IP and connected, and is working, but I can’t open a browser and use IPv4 to the HA or the NetBios name, but I can access my NAS through the static IP to that one through WiFi, so it’s my HA VM that a device on WiFi can’t access atm.

So I can’t see my HA through Google Hub or Alexa Echo, the two devices are on my WiFi and on the same Subnet as my Wired PC.

Can someone guide/help, what that can be the issue here.
(Have tried to turn off firewall on my NAS.)

First check that your wifi access point (might be your router) does not have a wifi segregation enabled or is running the wifi network as a guest network.

it should be set up ok



Please try and ping homeassistant.local and see what IP address that respond.

1 Like

what… it reply with a IPv6 address.
But why, my DHCP router have assigned a IPv4 to the MAC of the VM on the NAS…

Ok I have now turned off the IPv6 on my Homeassistant, and the wired PC is now getting a IPv4 address, but when using a WiFi Laptop and trying to connect, I still get the same error and if I ping homeassistant.local from the laptop, I get a IPv6 address, have made a ipconfig /flushdns, but diden’t help.

try ping -4 [address]
(the -4 forces IP4)

Then I get the right IPv4 to my homeassistant.local
But can still not access the homeassistant.local from a browser…

Probably your mDNS ain’t working properly (which is a router issue)
Just try with http://[IPADDRESS]:8123 :wink: