Can't access via domain, on mobile devices only

I’m new to Home Assistant, and recently got it up and running on a subdomain behind my Traefik reverse proxy, at I have port 443 redirecting to 8123 at that subdomain. This is all working great when I access it from multiple different desktop/laptop computers, even from outside my network.

I am, however, running into strange issues on mobile devices only. On the two different phones I’ve tried, in both Chrome and Safari, loading Home Assistant via the external domain name gives me the authentication page, but after I authenticate it just takes me to the ‘Unable to connect to Home Assistant’ page with a retry link. Every time I do this, Home Assistant gives me a ‘Login attempt failed’ notification, and also adds an additional refresh token on my profile page. I get exactly the same issue if I try to use the app via the external domain name. If I use the internal network address for Home Assistant, everything works fine on mobile both in browser and in app.

I checked the javascript console in Chrome mobile, but nothing is showing up when I try to log in. I’ve also tried a number of configuration changes with no luck. I just have no idea what about the mobile version of the site specifically could be incompatible with my configuration. Anyone run into anything like this before, or have ideas of what I could try? Thanks.