Can't access web interface after snapshot restore

Still trying to move from resinos to HassOS

After a fight with some faulty SD cards I am now struggling to restore my snapshot

I have set up 2 Pi3s on the same network 1 running my existing install which I don’t want to mess with till the new one is woking and a second to experiment with the new HassOS install.

Initial set up goes fine and I can access the web interface install samba and copy a cross a freshly created snapshot from my main install (snapshot file size is about 60Mb). I then run the snapshot on the new install. I have tried a straight restore and a wipe and restore but in both cases the same result.

I can still use samba and it looks like all the files are now in my config file but can no longer access the web interface. Tried waiting a few hour and and restart of the Pi but no change.

How long should a snapshot restore take?

Is there anything i should not restore from the resinos snapshot onto the hassos?

2 Likes

A little embarrassed to say I solved this one but thought it might help someone else to post the solution.

Before restoring the snapshot access is ok on my local network via PI’sIP:8123

Once restored this is not accessible.

I eventually realized my restor included ssl encryption and despite being on the same network needed to use https://PIsIP:8123 to reach the web frontend

oh the wasted hours!

7 Likes

I too am embarrassed.

I just migrated from a Pi to a VM by restoring a snapshot. My basic install on the VM was being accessed via HTTP. When the restore completed, I was frantically pressing F5. Only when I started Googling did I find this, added HTTPS and I’m in.

Thanks for taking the time to post this; you saved me hours.

1 Like

thanks, I had the same problem

+1 :smile:

Thank you for taking the time to post this. I was migrating hassio from an rpi to a vmware virtual machine running on a Win10 machine. After restoring the snapshot, I couldn’t access the web interface. I’ve been studying the logs for two days trying to get this virtual machine to work. Can’t believe I didn’t think to change the url to https. If I hadn’t ran across your post, I would have trashed the vm by now. Instead its working like a cadillac.

You save my life, you know

Also completely embarrassed too!! Did the same thing was like what the hey!?!?! Thanks for your post and your fix!