Can't add a new user

Hi all,

I hope someone can help me as I can’t add a new user in the users section of the configuration. I input the names and passwords then I get an “unknown error”, which in the logs is:

Logger: homeassistant.components.websocket_api.http.connection
Source: auth/providers/
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 23:30:43 (2 occurrences)
Last logged: 23:31:03

[547677266944] Error handling message: Unknown error
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/", line 18, in _handle_async_response
    await func(hass, connection, msg)
  File "/usr/src/homeassistant/homeassistant/components/config/", line 33, in websocket_create
    provider = auth_ha.async_get_provider(hass)
  File "/usr/src/homeassistant/homeassistant/auth/providers/", line 40, in async_get_provider
    raise RuntimeError("Provider not found")
RuntimeError: Provider not found

I have no idea how long this been a problem as generally my home assistant instance has been stable for ages, but I can’t add a user for the MQTT integration. As far as I have read the websocket api is related to the frontend part of the config yaml and that hasn’t changed.

(I am running the latest hassio on a Pi4 with 8 gb ram if it makes any difference)

thanks for any insight!

same here, I wrote a question, too. Did you solve it?

Sorry, no I didn’t. I kind of gave up on mqtt in ha and use the esphome API for anything I want to do. Would love to find a reason why though.

I finally solved it by removing the trusted networks from my configuration. Strange bug.

Yep, that worked for me too. I just commented it out, restarted and was able to add a user. After that, I uncomment the trusted network and on restart the new user was still there but unable to add any new ones. Very odd, but awesome work Helferlein!