Can't add Chrome shortcut to Home screen

So, on Android I open Home assistant in Chrome, hit the three dots on top right of the browser and there is no option to ‘Add to home screen’, instead there is an ‘Open Assistant’ menu option in its place which just opens the same page in full screen mode.

This is very annoying, and I assume is some metadata embedded in the HA home page that directs the browser to change the option displayed.

Any ideas ?


Doesn’t look like this on Chrome Browser. Except the Chrome browser and addresses your Pi with port 8123
here you can find the UI of Home Assistant, this site can be emptied on the home screen.

Read this thread. Use the port 443 solution.

Not Joy, tried port 443 and 8123, cleared all cache and cookies etc in Chrome, set airplane mode, and any URL I enter still results in the ‘Open Assistant’ menu option :

Chrome must be caching something somewhere, because after a full clear out of all history and cookies, type in just the URL of my HA I stall in airplane mode and get the screen saying ‘To use home assistant for the first time connect to the internet’

I just did it today on my android phone and it worked as expected.

I put in the address of the nabu casa webpage and then clicked the three dot menu and the “add to home screen” option was there. clicked it and it added fine.

No Joy. Cleared all the data our of chrome using the android system app, disconnects from the network (set airplane mode) open chrome and got the first time setup config, did not sign in, just went straight for a new page, entered my HA URL and just got the ‘Open Assistant’ menu option instead of add to home screen. It’s driving me nuts, where is Android storing this data…

Look in your apps location where all your Android apps are. It will be called Assistant. From the there you can drag it to your home page. That where mine ended up going.

1 Like

Genius…, Thanks :slight_smile: