Open HA as standalone within chrome

Hi all,

I want to use HA as an app on my android phone. In chrome I can use the “Add to homescreen” function, which basically works fine. But when I click on the new “App”, it’s not opened as an app but in the chrome browser.

According to this doc, I somehow need to set the “standalone” parameter:

When I have a look at my manifest.json of my HA installation, the display is set to standalone.

So why is it opened in the browser then instead of a standalone app?

Instead of using the chrome menu, wait until ha prompts you

Its a bug in Chrome. This is how I have made it work on multiple phones:

  1. Open HA in a Chrome browser window on your phone.
  2. Turn ON Flight mode.
  3. Tap the ‘add to home screen’ menu item.
  4. Select the app icon it asks you to do (in my experience there has only been 1 to choose from).
  5. Turn Flight mode back OFF.

After that the HA ‘app’ should work in its own full window screen, not a Chrome tab.


Also make sure you are running on 443 and not 8123, you can do a port forwarding on your router…
Also valid certificate is needed, otherwise you always have the url visible when you click the shortcut


I’m using port 8123 and don’t have those issues, I do have a valid cert however.

Strange, if I make the shortcut with 8123, I always have the url bar when I open the app …
So I also have port mapping enabled on my router from 443 external to 8123 internal , so when I make the shortcut then with 443, I have no url…
I use let’s encrypt

1 Like

Maybe it depends on Android version also, I am running v 9 , pie, that’s indeed more secured

I can confirm, that both solutions are working, but with a difference.

When I use the offline method, the website is added to the home screen, but not as a separate app. The chrome logo is in the bottom right corner and when I long press on the app icon and select “more information”, it just shows me the chrome app:

When I use port 443 instead of 8123 and add it to home screen, chrome actually created an app. And when I long click on the app icon and select “more information”, the app has the name “Assistant”:

So I’m assuming, that the second one (with changing the port) is actually the correct one.

Thanks a lot guys!

1 Like

yes, that was my solution also after lots of googling :slight_smile:
what android are you running?

Samsung S9+ with android 9 and chrome beta 72 :slight_smile:

ok, i think its indeed PIE related, before on android 7 , with my older smartphone, i could use a custom port

It’s not Pie related. I use a Honor phone with Oreo and this issue exist in there as well. It’s most probably a Chrome for Android bug. I user version 71, but I observed the problem also in v 70. I don’t know what did it look like before as I started using HA when Chrome was in version 70.
Windows version works fine and opens the HA page full screen for any of my HA access urls and ports. Chrome for Android behaves differently. Probably it will take months or years for Google to fix this.