Can't add google cast devices to HA, getting error when adding from Integrations

Hi Guys

Before the google cast devices were showing up in HA automatically but after updating to 0.115 few months back they aren’t showing up any more. I am running it on docker. When adding cast from Integrations, below warning is showing up in logs. Please help.

2021-01-07 07:45:01 WARNING (SyncWorker_30) [homeassistant.components.zeroconf.usage] Detected code that attempted to create another Zeroconf instance. Please use the shared Zeroconf via await homeassistant.components.zeroconf.async_get_instance(hass). Please report this issue.
Stack (most recent call last):
File “/usr/local/lib/python3.8/”, line 890, in _bootstrap
File “/usr/local/lib/python3.8/”, line 932, in _bootstrap_inner
File “/usr/local/lib/python3.8/”, line 870, in run
self._target(*self._args, **self._kwargs)
File “/usr/local/lib/python3.8/concurrent/futures/”, line 80, in _worker
File “/usr/local/lib/python3.8/concurrent/futures/”, line 57, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/local/lib/python3.8/site-packages/pychromecast/”, line 184, in discover_chromecasts
zconf = zeroconf_instance or zeroconf.Zeroconf()
File “/usr/src/homeassistant/homeassistant/components/zeroconf/”, line 20, in new_zeroconf_new
File “/usr/src/homeassistant/homeassistant/components/zeroconf/”, line 45, in _report

Oki, just updated the docker to latest version, now no above error in logs but still can’t find the cast devices in HA. when adding from integrations it says no devices found. But I can access those devices from my mobile

Never mind, fixed it. Started docker as Host network, fixed it, before I was just forwarding port 8123