Can't add RaspberryMatic as addon to HAssOS installation

I’m “starting” with my first HAOS installation/integration. I was able to successfully add a tasmota socket via MQTT to my installation. Next step I tried to add my different Homematic devices to my HA installation.
For that purpose I’ve checked the official Addons and saw that the official Addon is deprecated and that RaspberryMatic should be used instead. Going to that GIT page, checking the installation steps for the addon and tried to add as repository. After hitting “Add” it just waits some seconds before I get an “Unknown Error see supervisor logs” message. If I recheck the repository directly after closing it, the repo is “there” but does not provide any addon.
Supervisor logs just shows
2022-05-02 15:01:49 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /supervisor/options request
2022-05-02 15:01:49 ERROR (MainThread) [homeassistant.components.hassio] Failed to to call /supervisor/options -

does anyone know how I can fix this?

Best regards