Can't add TP-Link KP125M Smart Plugs

I’m trying to add TP-Link KP125M to Home Assistant and it only works as Matter device (no energy monitoring via Matter).
I can’t add it via TP-Link Kasa Smart integration and use its energy monitor.
I have many TP-Link devices on the network and all of them are working fine, except the KP125M I recently bought.
The error I’m getting when trying to add by IP: “Failed to connect”
I’m I doing something wrong or it is time to return these plugs? Kind of tired of TP-link messing with Home Assistant users…

Thank you awesome HA community!

I’ve only used the Tapo P100 plugs (Tp link), I had to set them up from their app first then add them on HA and promptly fire wall them. I did need to allow them to access a NTP server and a DNS server to function though.

All the energy monitoring features work etc.

I added them using the P100 integration under HACS. Their might be something specific to the KP’s there also, Worth having a look.

Just came here to echo this, bought 2x KP125M and was hoping to add them the same way as the existing KP115 plugs I have a dozen of. I am completely unable to add them via the Kasa integration. Discovery fails to find them, and entering the IP fails to connect. They work fine in the Kasa app, not that that does me any good.
Matter allows me to add them, but no energy monitoring available through that.
Hope this gets added soon!

1 Like

I opened up a Github issue, as I’m seeing the same problems: KP125M Smart Plug - Cannot be discovered or added with IP address · Issue #94947 · home-assistant/core · GitHub

I may end up returning it. I’m hopeful Matter will support energy monitoring in the future, but don’t want to bank on that.

1 Like

Thanks for creating the issue… I can’t return mine, what’s worse is that it means that future firmware updates to our existing TP-Link switches can kill the switches that we’re already using with Home Assistant :confused:

FWIW I was struggling to add these plugs via Matter, but eventually this is what worked for me (might help others):

  • Run Matter server in docker container
  • Added Matter integration in HA
  • Plug in KP125M (factory reset if needed)
  • Switch iPhone to 2.4Ghz network
  • Add Matter device via HA app, scan QR code, plug should be added fairly quickly
  • Plug automatically recognized in Kasa app (for other features)

I have multicast DNS still enabled with a Unifi network. No energy monitoring in HA of course, but should be enabled in the future whenever Matter spec is updated.


My plugs came with Matter QR stickers instead of being printed directly on the plastic. Makes me worried that the wrong stickers were placed on my devices. When I first opened the box some of the edges of the stickers weren’t pressed down fully. Out of the 4 plugs I received only one was successfully added to home assistant

This solved it for me. I had my phone on the 5g network and needed to be on the 2.4 to communicate with the plugs. Thanks for outlining your steps PalmTree!

1 Like

I can also add these via Matter, but I can’t get the power readings. I can only turn it on or off.

@Phobos-7 The current Matter spec does not yet support energy monitoring. Not sure if I’ll keep my plugs integrated with Matter. I think the Kasa / TP-Link integration has support for this.