Can't auth with long-lived access token

I’m trying to use the Auto Export app for iOS to get health data to my HA installation. I run it on a Raspberry Pi with HAOS behind a Synology reverse proxy with websockets allowed and a let’s encrypt cert.

The problem: I’m getting a 401 error and a log in HA showing the login as blocked. I can’t figure out why this is - there’s no other information and there’s no auth method other than using the token. Why isn’t HA allowing me to use a login token here? I tried with and without the colon in “Authorization”.

Logger: homeassistant.components.http.ban
Source: components/http/
integration: HTTP (documentation, issues)
First occurred: 10:48:52 AM (6 occurrences)
Last logged: 10:56:16 AM

Login attempt or request with invalid authentication from unifi.localdomain ( Requested URL: '/api/states/hae.hasssync_dietary_water'. (Auto%20Export/20240428.3 CFNetwork/1496.0.7 Darwin/23.5.0)

Your “Authorization” appears to have a “:” in it that doesn’t need to be there. Mine looks the same without the “:” and it works ok (although I don’t have the same infra setup as you).

Yeah I tried but this get the same error

Was the token issued by a user that has admin rights? I set up a separate user and note that I’ve got it set to Administrator.

Yup, used my own account which has full admin