Can't boot hassos? (x86_64 KVM VM)

I’m trying to get started with this and I’m having major problems. Seems all the downloads expect UEFI…and my “luck” of UEFI being a nightmare seems to be continuing.

Is there any BIOS image available instead?

I’m expecting to run this on a Linux (CentOS) KVM virtualization server which currently hosts several other VMs no problem. Apparently the official answer (based on RedHat 7) is “kvm/libvirt-manager doesn’t do UEFI yet” but I found some guides loading 3rd party packages…it now starts to boot but hangs “waiting for root device PATH=” and the last line is “clocksource: Switched to clocksource tsc” at 1.5 seconds after bootup. It seems to sit there forever (been about 15 minutes).

Help?

1 Like

Slight update, I got it to boot successfully once after many times of stopping/starting/recreating/re-downloading, but then it started failing at a boot loader screen I can’t get past.

Is there ANY way to use hassos with tried and true BIOS instead of UEFI???

Back to being unable to boot at all unless I re-download the new disk image.

Surely someone has some ideas???

Sounds like you’re something that hassos doesn’t have drivers for as your emulated hdd controller?

I got roughly as far last time I tried with basic command line qemu (no libvirt, using ovmf as drives to provide uefi functionality) I didn’t have time to make it all work in the end.

What did you ultimately end up doing to make Home Assistant work for you?

I’m trying different firmwares and I think one of the “older” OVMF EFI binary images may work slightly better, I more consistently get the boot menu but still can’t get it to boot.

It’s starting to look though like I may need to figure out how to use docker and how to do a vanilla OS install of something that uses normal BIOS and give up on hassos.

I’m running it on a Pi, … but I wanted to run it on x86 in a vm back when my SD card had died and while I was waiting for delivery of a new one.

Mine was getting stuck at “booting from hard disk”.

(note: this post has some superfluous spaces in that tags so that it will post)

You need to get the EFI firmware files.
I got them
cd /etc/yum.repos.d/ && wget http://www.kraxel.org/repos/firmware.repo
yum install edk2.git-ovmf-x64 -y

Then create your VM using virt-install (I used cockpit) using the qcow2 image

Then use virsh edit vm_name
In the < os> section after the < type> tag add
< loader readonly=‘yes’ type=‘rom’>/usr/share/edk2.git/ovmf-x64/OVMF_CODE-pure-efi.fd< /loader>
Your path may vary.

And then it booted.

Now on to configuration…

1 Like

Just wanted to post what finally worked for me…the edk2 one was highly unstable but the “old” one from the main repos was fine.

yum install OVMF
yum downgrade OVMF
yum versionlock OVMF

This ended up with the working version being OVMF-20150414-2.gitc9e5618.el7.noarch

And then when I made the VM in virt-manager, I checked the box “Customize before install” and picked from the dropdown to use Firmware “UEFI x86_64: /usr/share/OVMF/OVMF_CODE.fd”

That’s the only combination I found that was reliable booting. The yum versionlock is needed to stop it from re-upgrading to a broken version.

1 Like