Can't bypass login. Shown "Login aborted: Your computer is not allowed"

Hello, I am running HA in docker in windows 10. I now wish to bypass login using trusted network. However, I’ve encountered the error “Login aborted: Your computer is not allowed”.

I have tested this both on the same local network and on a reverse proxy. Same error in each case.

The error and my configuration.yaml:

This error was not reported on the forum as far as I know. Would anyone know why this is happening? Thanks!

Change to, see if that helps.

And you’re misunderstanding allow_bypass_login. It means if you have just one user, you don’t have to choose from the one-item dropdown. You’ll still get an error if you aren’t in the right IP range.

Thanks for the reply but changing to did not help.

My local network is on the 192.168.1.x. However it is giving me the same “Login aborted: Your computer is not allowed" error.

I tried accessing HA with different device on my local network and it still gives me this error. I can’t figure out why HA is saying that I’m not allowed…

If you run ipconfig in CMD on the device, what do you get?

My computer is in another language but it’s basically:
DNS suffix . . . . . . . . : HOMELAN
IPv6 address. . . . . . . : fe80::b08e:58b5:85a1:fc08%18
IPv4 address. . . . . . . . . . . . :
Subnet mask. . . . . . . . . . . .:
Default gateway . . . . . . . . . . . . .:

Weird. Is HA on the same LAN as your PC? Do you see anything in logs?

Yes it is on the same lan, running on docker on the machine.

Log doesn’t show any errors.

Does changing use_x_forwarder_for change anything? And change back to

Same error unfortunately regardless of if I include use_x_forwarder_for or not.

What ip address does resolve to?

It resolves to my external ip. I tried adding that to the conf but it’s the same error

Make sure you rebooted. This is my config:

    - type: trusted_networks
        - my.external.ip.address/32

Sorry to interrupt, but that looks interesting: so are we able to block (or allow) access to HA instance for specified IPs/IP ranges using auth_providers, right?

And the http directive looks exactly what I was looking for: Fail2Ban on HASS OS. :smiley:

This lets anyone log in without a password, as long as they come from a certain IP.

Basically. And it works on all HA installs, not just HA os.

Ah okay, so less security for the first one and easy security for everyone running HA if needed. Thank you for clarifying.

Sadly adding the external ip didn’t work either.

Got it working by adding the following to nginx conf:

proxy_set_header X-Real-IP       $proxy_protocol_addr;
proxy_set_header X-Forwarded-For $proxy_protocol_addr;

And then adding the docker ip to Trusted Networks and Trusted Proxy, which in my case is (You can find it in the docker command line when you click the login button)
I don’t actually know why tho…

1 Like

You know, this is the first mention of nginx in this thread. It would be helpful to mention everything relevant when you post a question.


I have this same problem. I cannot get HA to login on my google home device. I get the Login aborted. Your computer is not allowed error.