Can't configure my remote DuckDNS dns name in UI

Since a couple of weeks I am not able to Cast my dashboards to my Google Home v2 anymore.
Whet I try it by hand I receive this error message (iOS):
Failed to call service media_player/play_media. Unable te determine Home Assistant URL to send to device.
Configure internal and external URL in General settings.

I did had my internal and external adresses configured in yaml:

time_zone: !secret time_zone
external_url: !secret external_url
internal_url: !secret internal_url

So the real url’s are in my secrets file.

But that seems not the right place, So I went in the UI to the settings BUT there I am not able to change the Internet part of the settings.


Important is to mention taht remote access ts working perfectly with my DUCKSNS name!

Does anyone can help me with this issue?

And perhaps somone can help me with the error about the local certificates?
Kind regards, Bert