Can't connect Hue bridge to home assistant - can anyone help?

I’ve got a Philips hue hub v2 with latest firmware and I can’t get haas to connect to it . This is a cross post from the sub-reddit.

The ip address is fine

When I launch Haas I get the configure hue card

I click configure

I press the button on the hub

I click the “I’ve pressed the button” button

Dialogue goes away and phue.conf saved

Running on Mac OS X

However haas still won’t connect to hue. In the terminal window I get… attempting to connect to the bridge Using Using username from.config ERROR: Cannot reach the bridge.

I’ve queried the Hue Hub using the built in API and the username stored in the phue.conf is valid and registered…

Any ideas greatly appreciated!

This is the error I’m getting:

16-09-10 11:15:56 homeassistant.components.light.hue: Cannot reach the bridge Traceback (most recent call last): File “/Library/Frameworks/Python.framework/Versions/3.5/lib/python3.5/sitepackages/homeassistant/components/light/”, line 123, in update_lights api = bridge.get_api()
File “/Users/k*/.homeassistant/deps/”, line 615, in get_api return self.request(‘GET’, ‘/api/’ + self.username) File “/Users/k*/.homeassistant/deps/”, line 472, in request return json.loads(str(, encoding=‘utf-8’)) File “/Library/Frameworks/Python.framework/Versions/3.5/lib/python3.5/http/”, line 458, in read s = File “/Library/Frameworks/Python.framework/Versions/3.5/lib/python3.5/”, line 575, in readinto return self._sock.recv_into(b) socket.timeout: timed out

I’ve tried this…
curl http://hub.ip.address/debug/clip.html
And I get the expected response…
<html><head><title>hue personal wireless lighting</title></head><body><b>Use a modern browser to view this resource.</b></body></html>

I can ping the bridge from the machine with hass running on it

I’ve tried rebooting the bridge too,

I just can’t work out what is going wrong…

I have the same issue. Just started using Home Assistant and have (just about) managed to get it up and running on a windows 10 box with no errors. It has automatically found a wemo switch which works fine. I cannot get it to connect to my Hue Bridge (V2 latest firmware). If I run the configurator it seems to connect once I have hit the button on the bridge but then it does not find anything. I can also go into the hue debug screen on that computer and have checked that the unique password works. I have tried deleting and redoing the config a few times and tried manually adding the bridge:

platform: hue
host: 192.168.1.XX
allow_unreachable: true

But nothing shows up.

Any ideas?

I have also managed to get around this by moving the hue hub to another switch on the network directly connected to the box.