Can't connect to app with new phone

Hi all,

I have a new phone and am trying to remove my old phone (iPhone 7) and add my new phone (iPhone 11).

When I tried to login with my new phone, it tells me the following error message (partly in Dutch, sorry):

I now removed the integration for my old phone and de-activated the webhook for HA Cloud (webhooks popped up a few times when trying to Google my problem).

Also, when looking for the error message, the only thing I could find is that it’s something with a JSON file not being valid.
I checked the Log file, which says:

2022-01-09 12:09:41.517 [Error] [main] [WebhookManager.swift:582] urlSession(_:task:didCompleteWithError:) > failed request to ec3fa46c2ff84adbba863fae4e4688b6 for WebhookResponseUnhandled: Error Domain=NSCocoaErrorDomain Code=3840 "Invalid value around line 1, column 0." UserInfo={NSDebugDescription=Invalid value around line 1, column 0., NSJSONSerializationErrorIndex=0}

Also, I tried to login not via the ip address, but via the Cloud link, which resulted in the same error.

I’m out of ideas now of what I can try, so hopefully you all can help me :slight_smile:

Do you have any kind of reverse proxy in front of your Home Assistant? My hunch is it’s returning an error or something rather than allowing the request.

I’ve heard about reverse proxies, but actually don’t really know really what they are and didn’t (consciously :slight_smile: ) install any.

Also, I can still login with my iPhone 7 and when I just go via the browser.
Any way I can check whether this is the issue?

Are there any errors in your Home Assistant logs? The webhook is definitely writing in a way that means the app isn’t getting a response it likes.

Can you describe your setup and how you connect to HA?

Yes, the warning it gives is:

  • Received message for unregistered webhook long random string from cloud

I now also got the error message in this link, but the solutions don’t work for me.

Regarding my setup, I installed Home Assistant OS on a Raspberry Pi 4, then installed the app and connected. Not sure what else to share.

Thanks for your help so far!

Can you try deleting any existing mobile_app integrations before going through the sign in flow?

I already removed the integration for my old phone, but now also removed the other mobile_app integrations and the error is the same unfortunately.

I don’t know why and how, but it suddenly worked after setting the logging to debug for webhooks.

I now see a new webhook being created for my new phone, so it all works again.

Thanks for your help!