Can't connect to CC2652RB stick after unplugging a different USB adapter

I run zigbee2mqtt in a docker container on a Pi3 separate from my Home Assistant instance.

I recently upgraded to Slaesh’s CC2652RB stick to replace my old coordinator. Everything was working fine until I unplugged my Wyse Sense dongle from the Pi. Now the container can’t connect to the zigbee stick:

Zigbee2MQTT:info  2021-10-11 14:25:29: Starting zigbee-herdsman (0.13.138)
Zigbee2MQTT:debug 2021-10-11 14:25:29: Using zigbee-herdsman with settings: '{"adapter":{"concurrent":null,"delay":null,"disableLED":false},"backupPath":"/app/data/coordinator_backup.json","databaseBackupPath":"/app/data/database.db.backup","databasePath":"/app/data/database.db","network":{"channelList":[11],"extendedPanID":[221,221,221,221,221,221,221,221],"networkKey":"HIDDEN","panID":6754},"serialPort":{"path":"/dev/ttyACM0"}}'
Zigbee2MQTT:error 2021-10-11 14:25:50: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-10-11 14:25:50: Failed to start zigbee
Zigbee2MQTT:error 2021-10-11 14:25:50: Check for possible solutions
Zigbee2MQTT:error 2021-10-11 14:25:50: Exiting...
Zigbee2MQTT:error 2021-10-11 14:25:50: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:102:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
    at Zigbee.start (/app/lib/zigbee.js:66:27)
    at Controller.start (/app/lib/controller.js:110:27)
    at start (/app/index.js:95:5)

Here’s how the adapter is mapped to the container:

      - /dev/serial/by-id/usb-Silicon_Labs_slae.sh_cc2652rb_stick_-_slaesh_s_iot_stuff_00_12_4B_00_23_93_33_33-if00-port0:/dev/ttyACM0

I’ve tried everything I can think of short of re-flashing the firmware on the adapter. I’m stumped as to what I’m missing here. Any ideas on what I could try to troubleshoot this before I try the nuclear option?

Thanks in advance.

Frequently asked questions |

According to the FAQ your port is not mapped correct.

I tried mapping it by the port as well, but no change.

I’ve also check that the user has permission to talk to the device using:

test -w /dev/serial/by-id/usb-Silicon_Labs_slae.sh_cc2652rb_stick_-_slaesh_s_iot_stuff_00_12_4B_00_23_93_33_33-if00-port0 && echo success || echo failure


test -w /dev/ttyUSB0 && echo success || echo failure

both return success.

hi, i think , got the same thing.
i got to mount in my docker compose the ‘folder’:

 -  /dev/serial/by-id/usb-Silicon(blabla):/dev/serial/by-id/usb-Silicon(blabla)

and the same in zigbee2mqtt’s configuration.yaml.

device: /dev/serial/by-id/usb-Silicon(blabla)
 - /run/udev:/run/udev:ro

didn’t work

NOTE: Docker mount command does not support certain symbols like colon (Example: /dev/serial/by-id/usb-Silicon_Labs_http:_slae.sh_cc2652-_slaesh_s_iot_stuff_XX:XX:XX:XX:XX:XX:XX:XX-if00-port0). Error Message: bad format for path. You can create a persistent device name with udev or create a symbolic link

(my adapter have a litle name)

Did you try

test -w /dev/ttyACM0 && echo success || echo failure

inside the container?

Thanks, I hadn’t thought to do this, I just did and it returned ‘success’.

Re-flashing the stick did the trick. What a waste of time…

Thanks for the help