Can't connect to Govee Hygrometer

I’m running HAOS inside VMWare Player on a mini-pc.
I’m using an Avantree DG40S Bluetooth USB adapter.
I’m trying to connect to a Govee Room Thermometer Hygrometer H5075.
I’ve installed Bluetooth - Home Assistant and got it working by doing a bluetoothctl - power off, power on, scan on every time I restart HA. It just shows one device, the adapter itself - I don’t know whether that’s correct.
I’ve tried to install Govee Bluetooth - Home Assistant but it just gives the message “No devices found on the network”.

I’ve also tried installing GitHub - custom-components/ble_monitor: BLE monitor passively monitors BLE sensors (Xiaomi, Qingping, ATC, BlueMaestro, Brifit, Govee, Kegtron, Moat, Inkbird, iNode, Yeelight, RuuviTag, SensorPush, Teltonika, Thermoplus and Thermopro) as well as the above, and that doesn’t seem to make any difference.

Can anyone help please?

If Bluetooth is working properly and the sensor is on it’s range it should detect it automatically.

Try to enable debug mode on your Bluetooth integration and look for some clue on the logs.