Can't connect to home assistant from old Android Tablet

Hi all,

Can you connect to Home Assistant from old Android Devices? (ifive mini 4s; android 6.0.1)

I wanted to use an old android tablet I had laying around as a wallmounted dashboard for Home Assistant. Unfortunately, I ran into some problems… When I try to connect to Home Assistant I am allowed to login but after logging in I just get a white screen with a blue Home Assistant logo in the middle.

In the browser, that’s it, but I got a message in the companion app that it was a network connection issue. This version of Android doesn’t have lot of network-configuration options and I feel like I tried them all.
Other devices within the same subnet have no issues connecting…

Do you guys have any idea what could be the issue?


1 Like

I have recently used a 2013 low spec tablet and no issues albeit really slow… How did you try to connect internal/external, same network, SSL? Do you have connection issues from other android devices in the same network?

I tried multiple variations, internal without ssl and via ssl and a reverse proxy both same subnet and different subnet etc. I don’t have any other android devices, but on my iphone and laptop I have no issues.

make sure that android system webview up to date on the device, if using a custom ROM then you need to make sure you are using googles version of webview and that is set as the default. If a stock ROM with no webview then make sure chrome is up to date.


I had that same issue and the only browser that I was able to have access was Opera.

That did the trick, thank you so much!

All I had to do was update System Webview from the play store.

I was having a similar problem with Kavita. This ended up solving the problem. You are the GOAT.

1 Like