Can't connect to Home Assistant locally from my PC

I have several computers, I usually connect to Home Assistant on my Mac. I need to do some work from my PC, but it won’t let me connect. It has connected sporatically, but before I could do anything, it would go into a ‘reconnecting’ dialog, then the page won’t load at all.

I have tried both using the URL (the same URL on both computers) and homeassistant.local:8123

Both computers are connected to the same ethernet hub.

Does anyone have any suggestions to what might be going on?

I ran the Windows Network Diagnostics, and it comes up with the message

‘Resource is online, but isn’t responding to connection attempts’

After a short while, it will connect again on it’s own, but if I try to do anything, it will disconnect shortly after. This only happens on the PC, neither of my Mac computers nor my iPhone have any issues.

I’m running on a Home Assistant Blue.

I get this on an iPhone with an HA Blue.

Once the app loses its connection and shows the cog, iOS will refuse that connection completely. Chrome says no. Safari says no. Private browsing says no. Other sites are visible, and other machines can still connect to HA.

Eventually it goes away. Tends to leave me with a notification of a failed login attempt, mind.

Can you still connect on other machines? Can you still connect to other sites? Do all browsers on the problematic machine agree?

1 Like

Check the network settings of both devices, especially the subnet mask, which should be the same on both devices.
IP address should be the same in the fields where subnet mask have 255 listed.

Next check that you can ping the HA installation from the windows machine and also try pinging the router and maybe even google at

If this is working the check the logs on HA when making a connection attempt.
Try that also with the firewall on the windows machine disabled. The firewall might be located in a security software suite or it can separate software packages. If none of these is used, then Windows own builtin firewall will probably be active instead.

1 Like

None of my other Mac computers have this issue that I have noticed. I occasionally have what you describe in the HA app on my iPhone, but that’s rare and a restart fixes the problem for a while.

I have no problem browsing the internet on the PC, just Hone Assistant. I have this issue on multiple browsers on that PC (I checked Chrome and MS Edge, don’t know if I tried ForeFox). This isn’t like the app needing to restart in my iPhone (which happens rarely, maybe once every week or two), this happens within minutes of it establishing a connection. I can maybe click on a few tabs before it disconnects.

I have shut down the PC for the evening, but I’ll check your suggestions next time I have it on. Thanks.