Can't connect to Raspberry but can connect to HA via SSH


#1

Hi,

Just got myself a Raspberry Pi 3 B+ and followed the steps to install Home assistant on it and everything is working currently pretty much ok in terms of HA. When I was trying to start to setup a backup solution for HA I started to dig into the USB solution but could not get a usb stick to mount according to the instructions on the page.

On the page its instructed to use command sudo mount /dev/sda1 /media/ but the sudo isn’t recognized as command when I logged via Putty to HA (as user root). I then tried the same command without _sudo_ but that ended into (mount: mounting /dev/sda1 on /media failed: No such file or directory) When googling a bit I then understood that I probably should log in to the Pi itself (had not done that before) and just fired up Putty again with same ip/port as with HA but when I entered the username as pi and tried entering password as raspberry it’s just saying “Access denied”.

Then googled some more and found out that maybe SSH is not on by default on the Pi (even though I could enter to the HA side) so I added a “ssh” file to the SD card (root folder of it, same where home assistant seemed to be) but still no luck.

Any idea’s where I’m failing here? Could be some very basics as I’m new to the Raspberry & HA.


#2

The important missing information is how you installed Home Assistant. Is it Hassio, hassbian, or something else?


#3

It’s hassio (HassOS 1.13)


#4

Then there is no pi user. The password is not raspberry.

You’re not going to get mount capabilities in the ssh add-on. You don’t have Linux tools available to you in HassOS.


#5

When you install the ssh addon (hint: do it!) in the configuration file you will put in a password. That password is for root. So when you ssh to your pi the command would be "ssh [email protected] and then you will be prompted for the password you assigned.
Keep in mind that when you get there… you are “kinda root”. The hass.io operating system you are “rooting into” is not a full implementation of linux.


#6

It’s also not the host OS


#7

Thanks for the guidance on this. After reading this I first time understood the differences between the different ways of installing HA and subsequently that not all the tricks and tips apply to my install.