Can't connect to SMB share from MacOS High Sierra

Did the upgrade to High Sierra on my MacBook Pro and now I can’t connect to’s SMB share. It still works (and has worked flawlessly for months) from my iMac with MacOS Sierra.

When making the attempt via the Connect to Server dialog in Finder (to smb://hassio.local), it tries for about 3 seconds and then responds with:

There was a problem connecting to the server “hassio.local”. Check the server name or IP address, and then try again. If you continue to have problems, contact your system administrator.

It never asks for my credentials, and I verified there aren’t any cached in Keychain. The MacBook has no problem resolving “hassio.local” to the correct local IP address, but I tried mounting directly with the IP anyway and got the same result.

I’ve been digging around for clues on SMB issues with High Sierra but haven’t gotten anywhere. Is anyone experiencing this issue or is it just me?

Have you tried to connect via the direct IP? hassio.local doesn’t work for me, too.

I sometimes encounter that problem, reboot mac usually fixes. Cheers

Yep, I tried that. Same result.

Thanks, that was the first thing I tried :slight_smile: No effect.

Well I finally solved it, took many hours of sleuthing. Apparently it’s an issue with a kext installed to help Android emulators run…somehow, that kills all SMB connections. So it wasn’t actually related to my High Sierra upgrade, I think the timing of that was coincidence with the installation I did of an IDE recently.


I use this free little tool: ConnectMeNow. This works all the time. You can download it here.

Hi, I realize this thread is quite old but I would like to know how this tool works? Do you just click execute automount or is there a way to connect to my smb server of choice?