Can't disable debug logging [Fixed]

I’m trying to disable debug logging for an integration by clicking the 3-dot menu → “disable debug logging”. However, it instead just downloads the log instead of disabling debug logging. How can I just disable debug logging?


Edit: I ended up upgrading Hass to the latest version and restarted. I guess that fixed it.

I have the same thing happening with 2023.06.1 - tried rebooting but still the same.

Same issue, I disable zigbee debugging it downloads the log, says it’s turned off but then re enables
2023.06.1 also

Same issue here…

Same here. Home Assistant 2023.5.4

Enabled global debugging from configuration.yaml
Then disabled it returning to warning and to info

Debug is still on, and filling the log like crazy.

Same issue here
Home Assistant 2023.6.2
Supervisor 2023.06.2
Operating System 10.3
Frontend 20230608.0 - latest

Same thing happening to me with a Sonoff Zigbee Plus.

Same issue here, also had enabled debug for integration, disabled it and downloaded the log, but the log file home-assistant.log gets filled like crazy with all sorts of debug logs.

– EDIT –
Did run the service:

service: logger.set_default_level
data: 
  level: error

to set the level back to error (in my case i was always running error mode)

Sorry, maybe I just don’t see it, but what was the solution? I cant figure it out.

Have the same issue also with ZHA. has persisted across multiple version upgrades. anyone have a fix?

In my case I had the log level debug set in my configuration.yaml for smartthings. Switching it to info for the homeassistant component worked for me.

cc @Peter_Jancar @stub2k2

logger:
  default: info
  logs:
    homeassistant.components.influxdb: critical
    homeassistant.components.smartthings: info
2 Likes

This fixed it for me too… all this time and i had it defined in config… doh

Glad I found this. Me too – not sure why debug was turned on in the config file. Do I need to reboot to get the change to configuration.yaml to take effect? (Clearly, if I don’t know the answer to that, I probably shouldn’t be editing configuration.yaml. :wink: )

EDIT: I though just doing a lightweight “Quick reload” would do it, since it purports to apply yaml config changes, but that didn’t do it. A full hardware reboot did the trick. Perhaps there’s a middle ground.