Can't download .bin file from ESPHome

I have been using an Athom Smart Plug v2 for a while now. I wanted to configure a second one just now and ran into some issues with it. Long story short, I need to reflash it and need a .bin file to do so.

I tried to pull it from my working plug, but I get the following error:

INFO Reading configuration /root/config/schuur-opladers.yaml...
INFO Detected timezone 'Etc/UTC'
Failed config

button.factory_reset: [source /root/config/.esphome/packages/43f53298/athom-smart-plug-v2.yaml:108]
  Platform not found: 'button.factory_reset'.
  platform: factory_reset
  name: Restart with Factory Default Settings
  id: Reset

ESPHome seems to check with the most recent package on Github which has changed compared to the pre-flashed version the plug came with I guess? I dont know how to solve this issue though. I also cant rename the plug anymore since it will throw the same error.

can you show us that code?


What version pf esphome are you running? Sounds like it is out of date.

I have just done two Athom v2 plugs OTA updates with above GIt YAML and no problem. However I had a compile error on two ESP32 modules and had to backup all my YAML, remove ESPHome dashboard, delete folders and start again. Problem solved.

I was indeed running a slightly out of date version of esphome. Did not think that that could have this particular effect. Thanks a lot! Just updating esphome solved the issue.

The factory reset stuff was introduced in esphome 2022.9 ESPHome 2022.9.0 - 21st September 2022 — ESPHome