Can't flash new ESP32s

Hi all,

Just to cover off the common questions:

  • I’ve tried searching the Forums for an answer; unfortunately most of the answers I’ve found are about ESP32s not appearing in HomeAssistant once they’ve been flashed. That’s not my problem.
  • Installed the drivers
  • I’m not new to Home Assistant or ESPHome.

I’ve been trying to set up some new ESP32s using the interface in Home Assistant. I use Google Chrome and I have access to all 3 major platforms (Mac, Windows, Linux) - my personal computer is a Mac.

For ages I’ve connected to my HA instance through its https:// address, clicked on ESPHome, Clicked +New Device, followed the wizard and been presented with a screen to choose a device connected using a USB cable plugged in to my laptop. Now when I get to that screen, it doesn’t list the device plugged in.

I’m aware that’s a screenshot of it not working which probably isn’t useful. I posted it just to be clear about where the process is failing for me.

What I’ve tried

  • various ESP32s
  • Different cables
  • Chrome running on Windows, Ubuntu and Mac
  • Using chrome://settings/reset to reset Chrome to default

The only thing that hasn’t changed is the HA instance. But since the communication to flash the ESP32 is initially done in the local browser I can’t figure out why that would be relevant.

Has anyone seen this before of think of anything I can try? I haven’t been able to flash an ESP32 for a few weeks and it’s getting really annoying.


What is the model of your esp32? I have recently had this problem with wled and new esp32 devices.

Why not plug it into your HA machine?