Can't get AndroidTV to work on Nvidia Shield


is there anything special you needed to do to get the androidtv integration connected to your Shield?

I have enabled developer options and turned on debugging over the network (which I think is required) but I still fail to connect when attempting to configure the integration. I’m also running the latest version (9.1.1) of the Shield software.

I have successfully set up the androidtv notifications integration and those notifications are working fine so the basic infrastructure is there.

I just don’t know what I’m missing with the androidtv integration.

Once you enable both developer mode and debug you have to reboot the system. Then your HA should auto detect the Shield as an AndroidTV.

If it doesn’t, manually add an AndroidTV device and put in your Shield IP address.

1 Like

I figured it out.

I didn’t realize I had a prompt to accept debugging commands on the Shield.

I had tried it again with a failure to connect and then just happened to turn on the TV shortly after that and there was the prompt (I never saw that prompt before now tho - maybe it had timed out? :man_shrugging:). I accepted it and then had to go back in to HA and set up the host manually again and it connected.

Thanks for the help tho.