Cant get bluetooth to work - spent hours of research

Hi there

I think about getting a smart lock from Aqara (N100) which works via Bluetooth. Before I make the purchase I wanted to enable Bluetooth in order to prepare my system for it. I literally spent hours of research on how to do so but cant get it to work :confused:

environment
Raspberry Pi 4+ with Home Assistant OS 6.6, core-2021.11.5 installed on a SD-card

installed components

device_tracker:
  - platform: bluetooth_tracker
    track_new_devices: true

as well as the passive ble monitor component (GitHub - custom-components/ble_monitor: BLE monitor passively monitors BLE sensors (Xiaomi, Qingping, ATC, BlueMaestro, Brifit, Govee, Kegtron, Moat, iNode, Yeelight, RuuviTag, SensorPush, Teltonika and Thermoplus))

I face the issue that the system doesnt recognize the internal bluetooth-adapter and I cant connect to any bluetooth-device like a speaker or beacon. the passive ble monitor component cant find the bluetooths MAC-address or device-id.


my questions
do I have to enable bluetooth in the config.txt file of the hassio-boot partition on the SD-card or somewhere else?

do I have to enable it via SSH? I installed the SSH add-on but it seems that I can only enter CLI-commands

I used the forum search and had to realize that its apparently not that easy to enable Bluetooth within Home Assistant.

would appreciate your help and hope to help others as well who struggle with bluetooth :frowning:

regards

Andrew

so I found the issue, just wanted to let the community know in case somebody runs into the same problem.

I had dtoverlay=pi3-disablt-bt in my config.txt. This file is located on the SD-card or storage where your OS is.

I had to disable the function via a hashtag: #dtoverlay=pi3-disablt-bt