Home Assistant Community

Can't get duckdns to work

#1

I am struggling to get DuckDNS to work with my homeassistant so I cannot view the status of my home, or make changes to the automation unless I am on my home network. Obviously this is a problem. I have followed instructions as closely as I’ve known how to:

I’ve got an account on duckdns
I’ve got incoming port 80 forwarded to 192.168.x.x (my raspberry pi)
I’ve got incoming port 443 forwarded to 192.168.x.x (my raspberry pi)
When I install duckdns on home assistant, I edit the configuration file to look like:

{
  "lets_encrypt": {
    "accept_terms": true,
    "certfile": "fullchain.pem",
    "keyfile": "privkey.pem"
  },
  "token": "mytoken",
  "domains": [
    "myserver.duckdns.org"
  ],
  "seconds": 300
}

However, when I start the duckdns, this is the log I get:

# INFO: Using main config file /data/workdir/config
+ Account already registered!
Sat Mar 30 14:36:47 CDT 2019: KO
# INFO: Using main config file /data/workdir/config
Processing https://myserver.duckdns.org
 + Creating new directory /data/letsencrypt/https://myserver.duckdns.org ...
 + Signing domains...
 + Generating private key...
 + Generating signing request...
req: Hit end of string before finding the equals.
problems making Certificate Request

…and myserver.duckdns.org does not connect to anything from a browser. What steps should I take?

0 Likes

#2

What type of Home Assistant installation? Docker? Virtualenv?
I have nothing in my configuration for LetsEncrypt.

0 Likes

#3

Is it possible you are actually going to myserver.duckdns.org? Have you created a duckdns account and domain? That domain name is what goes where the sample says myserver

1 Like

#4
0 Likes

#5

I have the same issue - I was wondering if you managed to get this working sakau2007? I am running Hassio on a Pi 3.

I have noticed that there is nothing in my ssl folder, so when it is pointing to fullchain.pem and privkey.pem in the configurator there is nothing there. Any ideas?

0 Likes

#6

What addon from Hassio did you install? Duck DNS? That’s what you need. It i\handles the LetsEncrypt part automatically for you and creates the certificates if properly set up/

.https://www.home-assistant.io/addons/duckdns/

0 Likes

#7

Hi,

Thanks for responding. Yes I’ve installed the DuckDNS add on, settings are:

  "lets_encrypt": {
    "accept_terms": true,
    "certfile": "fullchain.pem",
    "keyfile": "privkey.pem"
  },
  "token": "token",
  "domains": [
    "https://domain.duckdns.org"
  ],
  "seconds": 300
}

and within my config:

  base_url: domain.duckdns.org:8123
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

I have ports 80 and 443 forwarded to 10.0.0.x:8123 on my router. Log for DuckDNS add on is:

INFO: Using main config file /data/workdir/config
Processing https://domain.duckdns.org

  • Signing domains…
  • Generating private key…
  • Generating signing request…
    req: Hit end of string before finding the equals.
    problems making Certificate Request

As I said, the /ssl directory is empty. I have restarted the add-on several times and restarted home assistant several times too. Any ideas?

Thanks

0 Likes

#8

Take the “https://“ out of the domain. That makes it a URL which is not the same thing.

0 Likes

#9

Thanks, I’ve changed that back - but in my fiddling I have already tried that way which didn’t resolve the certificate issue.

0 Likes