Can't get low precision fix

Loving Zanzito, bought a license, using it with Find integration as well.

Unfortunately a problem has come up - starting about a week ago, the GPS got “stuck” and wouldn’t update. After uninstalling and reinstalling, it just never gets a fix with low-precision mode - only when I turn on high precision.

Anybody experience this? Any tips? I don’t want to turn on high precision (I really don’t need it, especially with using Find as well). Nothing has changed as far as the phone or phone settings are concerned. I tried rebooting, reinstalling, playing with permissions, all to no avail.

Same issue. Any hint?

Eventually I flashed my phone’s firmware, complete reinstall of everything, and it started working again. No idea. I do get regular crashes though.

Would be great to see updates to the app - or at least some indication that it is being actively worked on. I like it a lot, it just could use some attention.

After struggling I moved to tasker + autolocation.

I send restapi requests to HA based on geofences. So I also save battery from GPS tracking.