Can't get properties to work with Node-RED

I’m wasting dozens of hours with trial and error trying to get simple properties to work with Node-RED.
How do I input the “azimuth” property in, for example, the “sun.sun” entity?
I’m trying to set a trigger for when the azimuth hits 210, shades drop. I’m copying the property from the object debug:

I copy/paste the path here into a trigger: state node:

But I get “invalid property”.

I’m used to the ISY-994i easy to use programming interface. Node-RED seems to introduce much more non-intuitive complexity. Would help if the Property fields would drop-down allowable data!

How am I supposed to know proper formatting for these Property fields?


I do see that sometimes (it’s sporadic) you can get a drop-down menu on some property fields (not all fields, just certain triggers).
Those drop-down fields do NOT match the debug property paths. Not sure why Node-RED even has a copy property path capability if it doesn’t match the drop-down fields.

Node-RED needs a usability check/feedback forum. It has great promise but is clearly dominated by programmers who aren’t concerned about usability for new programmers.

Thank you Mauricio yes I tried that. Still no joy. Also tried changing property to new_state.attributes.azimuth.

Sorry, I posted the wrong screenshot above. Here’s the correct one.

Yes! That works!
My take away is you have to know 1) State type (fyi I left mine on “number” not “string” and it still works?)
2) Property type (string, number or boolean-- and I can’t find ANY field descriptions that tell you that!)
and 3) Property string, which is sometimes on a drop-down menu, but is NOT for “switch” nodes that depend on msg.“text” property fields.
So arcane!

sun.sun returns only the strings “above_horizon” or “below_horizon”. When you set State Type to Number, the trigger node returns payload: NaN because it’s Not a Number.