Can't get remote_homeassistant to work - what might be wrong or what is a better setup?


I just recently got a summer house and have setup an Ubuntu server running HAOS in a VM. This is my secondary instance. I have used the “Cloudflare setup” (and own domain) to be able to access it remotely. It all works fine with the companion app and web access from home.

At home I run my main instance of HAOS in a VM on a NAS, here I use the “Duck DNS/NGINX combination” to access it remotely. It works fine. I might change to the “Cloudflare setup” in the future to have the two instances aligned.

Now I would like to be able to see sensors and such from my secondary instance of HA at my main instance HA at home.

For this I have installed the Remote Home-Assistant add-on on both instances and followed the guides (I guess) correctly;

  1. On the secondary instance of HA I created an Access token, edited the configuration.yaml and setup the Remote Home-Assistance integration as a remote instance.

  2. On the main instance of HA I setup the Remote Home-Assistance to add a remote instance and put in the necessary information.

The “circle” spins for a good while and then I get the error message “Failed to connect to server”. I tried remove the checkboxes for Secury and Verify SSL, but without any luck. I tried to add “https://” in front of the host name. Also both instances have been re-started.

Any ideas what can be wrong and/or suggestion/or troubleshooting on how to get this working?

To tie sensors they would both need access to the same base information. That means setting up an MQTT broker that they both talk to or using webhooks to pass info back and forth or possibly something like zerotier to connect the networks together virtually.

I have not used that remote software so if you want more info on that you may need to go to the source. I do use webhooks for some notifications and zerotier for file sharing and back-ups for a similar situation.

Thanks for your answer. Well I will see if I can get this add-on to work firstly, as this will expose the sensors on my main instance. If can’t get it working I will look consider other solutions.

You’re probably trying to connect to the wrong port. If you’re connecting to your remote instance through Cloudflare Tunnels, you should be using port 443, which is the port for HTTPS traffic. Port 8123 is only for connecting to your HA instance directly from your local network. Just use the full https:// URL and you should be able to leave the Secure and Verify SSL checkboxes enabled.

1 Like

Correct, thanks.