Can't get RFXtrx433XL to work on Hassio

Hello everybody, i’m new here!
Have been playing with Hassio for a couple weeks now and am well on my way to automating my house.
Up untill now just reading all the infrmation on here was more then enough to keep me going, but now i’m completely stuck

I’m trying to get rfxtrx working, have read every possible thread on this forum and the entire internet (i think), but still no luck


  • Raspberry Pi 4, 4GB model
  • RFXtrx433XL
  • Latest Hassio, Home Assistant 0.101.0
core-ssh:~# dmesg | grep FTDI
[    1.694748] usbserial: USB Serial support registered for FTDI USB Serial Device
[    1.694869] ftdi_sio 1-1.1:1.0: FTDI USB Serial Device converter detected
[    1.696699] usb 1-1.1: FTDI USB Serial Device converter now attached to ttyUSB0
core-ssh:~# ls -al /dev/serial/by-id
total 0
drwxr-xr-x    2 root     root            80 Oct 31 17:55 .
drwxr-xr-x    3 root     root            60 Oct 31 17:55 ..
crw-rw----    1 root     audio     166,   0 Oct 31 17:55 usb-0658_0200-if00
crw-rw----    1 root     audio     188,   0 Oct 31 17:55 usb-RFXCOM_RFXtrx433XL_DO462DW8-if00-port0

My configuration.yaml looks like this

  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433XL_DO462DW8-if00-port0
  debug: true
  dummy: false

  platform: rfxtrx
  automatic_add: true
  • I’ve also treid /dev/ttyUSB0 for the device path, also without any luck.
  • Rebooted the entire Pi multiple times
  • Tried different USB ports, even with a powered USB hub
  • Tried pushing buttons on my 433Mhz remote/switches
  • Checked my config for errors

Still… nothing
The Hassio logs look normal, no errors, but also no mentions of rfxtrx or USB devices. It’s like it’s not even trying to load the rfxtrx integration

So, here i am, asking for help. Is there anybody out there that got this particular piece of hardware working on Hassio? Note: It’s the newest RFXCOM, the RFXtrx433XL

Thanks in advance,

1 Like


Try adding debug logging to see if the messages are coming through

  default: debug
    homeassistant.components.rfxtrx: debug

Hi, thanks for your reply. I added the debug logging as suggested. Sadly, no incoming messages from rfxtrx show up when i push physical buttons. Below are all log entries that contain ‘rfxtrx’

2019-11-01 15:58:37 DEBUG (MainThread) [homeassistant.bootstrap] Setting up {'mqtt', 'rfxtrx', 'device_tracker', 'default_config', 'updater', 'person', 'device_automation', 'system_health', 'history', 'webhook', 'hassio', 'asuswrt', 'lovelace', 'ssdp', 'map', 'api', 'mobile_app', 'tts', 'zone', 'zwave', 'notify', 'met', 'panel_custom', 'config', 'auth', 'websocket_api', 'group', 'zeroconf', 'script', 'http', 'ifttt', 'logbook', 'frontend', 'cloud', 'switch', 'automation', 'sun', 'onboarding'}
2019-11-01 15:58:38 INFO (MainThread) [homeassistant.setup] Setting up rfxtrx
2019-11-01 15:58:41 INFO (MainThread) [homeassistant.setup] Setup of domain rfxtrx took 3.8 seconds.
2019-11-01 15:58:41 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event component_loaded[L]: component=rfxtrx>
2019-11-01 15:58:41 INFO (MainThread) [homeassistant.components.switch] Setting up switch.rfxtrx
2019-11-01 15:58:54 WARNING (MainThread) [homeassistant.components.switch] Setup of platform rfxtrx is taking over 10 seconds.
2019-11-01 16:02:20 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.2927857904] Sending {'id': 6, 'type': 'result', 'success': True, 'result': {'latitude': 52.7668, 'longitude': 5.1048, 'elevation': 0, 'unit_system': {'length': 'km', 'mass': 'g', 'pressure': 'Pa', 'temperature': '°C', 'volume': 'L'}, 'location_name': 'Home', 'time_zone': 'Europe/Amsterdam', 'components': {'mqtt', 'rfxtrx', 'device_tracker', 'default_config', 'notify.smtp', 'updater', 'person', 'weather', 'notify.mobile_app', 'history', 'system_health', 'homeassistant', 'device_automation', 'webhook', 'binary_sensor.updater', 'persistent_notification', 'switch.rfxtrx', 'lovelace', 'ssdp', 'asuswrt', 'hassio', 'map', 'alert', 'lock', 'api', 'switch.zwave', 'mobile_app', 'binary_sensor', 'tts', 'lock.zwave', 'cover', 'zone', 'zwave', 'sensor.zwave', 'met', 'panel_custom', 'notify', 'climate.zwave', 'notify.pushover', 'sensor', 'config', 'auth', 'websocket_api', 'cover.zwave', 'stream', 'group', 'zeroconf', 'script', 'http', 'ifttt', 'binary_sensor.zwave', 'climate', 'light.zwave', 'logbook', 'fan', 'frontend', 'recorder', 'light', 'cloud', 'weather.met', 'switch', 'automation', 'logger', 'sensor.asuswrt', 'sun', 'fan.zwave', 'system_log', 'onboarding'}, 'config_dir': '/config', 'whitelist_external_dirs': {'/tmp', '/config/www'}, 'version': '0.101.1', 'config_source': 'yaml'}}
2019-11-01 16:02:44 DEBUG (SyncWorker_7) [homeassistant.util.json] JSON file not found: /usr/src/homeassistant/homeassistant/components/rfxtrx/.translations/en.json
2019-11-01 16:02:46 DEBUG (SyncWorker_7) [homeassistant.util.json] JSON file not found: /usr/src/homeassistant/homeassistant/components/rfxtrx/.translations/switch.en.json

Well, ended up being a hardware issue. Returned the RFXCOM and got a new one, now at least the devices show up, but… there is a new issue now, i’ll stick that into a new topic.

HI @jasper1983x - thanks for sharing your experience

I have just ordered a RFXCOM for my Somfy blinds - can I please ask, where are the instructions for installing/configuring the device on the RaspberryPi ie drivers etc.

Thanks in advance!

1 Like