Can't get rid of automation - only automations in automations.yaml are editable

Having trouble and trying to simplify things and get back to a known working configuration.

Trying to get rid of my only automation, but I can’t get rid of the automation - Error - only automations in automations.yaml are editable. If I try to delete, Can’t get rid of automation - only automations in automations.yaml can be deleted.

Please help. Very new at this and experiencing a lot of frustration.

1 Like

Same problem here.
“Enkel automatiseringen in automations.yaml kunnen verwijderd worden”

Same problem here. In fact, this is exactly the kind of mess I warned people about years ago when they started GUIfying every configuration item. The result is an indeterminate state where the GUI won’t let you delete an entity that is not in any of the YAML files and is wreaking havoc in the real world.

Same mess if I try to disable it. As soon as home assistant restarts, the automation reactivates. How do we fix this?

I would add that the Migrate button also doesn’t work. Is there any way to delete these automations if the GUI refuses to do anything useful? At least with YAML it’s either there or it isn’t.

See Unhelpful message "Only automations in automations.yaml can be deleted." · Issue #18631 · home-assistant/frontend · GitHub

Maybe I was able to get rid of those undeletable/uneditable automation dashboard entries by doing the following:

Web interface > Developer tools > select tab “YAML” > under section “YAML configuration reloading”, click “ALL YAML CONFIGURATION”.

If it’s still actual:
I got rid off these automations by creating some dummy automations with the same names in automations.yaml, restarted HA, deleted them in the yaml again and restarted HA again. After that they were gone.

I tried 4 or 5 proposed solutions before this and this was the only thing that worked. That and I think it would have worked for the people who posted and got those other 4 or 5 responses too. Thank you very much!