Can't get sensor to act as binary

Tags: #<Tag:0x00007f7399d21248>

Hi Justin, yep my old and new values seem to be changing from False to True as they should, and state is changing from off to on, etc:

2017-09-10 01:24:57.475 Detail, Node002, Refreshed Value: old value=false, new value=true, type=bool
2017-09-10 01:24:57.475 Detail, Node002, Changes to this value are not verified
2017-09-10 01:24:57.475 Detail, Node002, Notification: ValueChanged
2017-09-10 01:25:00.820 Detail, Node002,   Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x02, 0x03, 0x30, 0x03, 0x00, 0xc0
2017-09-10 01:25:00.820 Detail, 
2017-09-10 01:25:00.820 Info, Node002, Received SensorBinary report: Sensor:192 State=Off
2017-09-10 01:25:00.821 Detail, Node002, Refreshed Value: old value=true, new value=false, type=bool
2017-09-10 01:25:00.821 Detail, Node002, Changes to this value are not verified
2017-09-10 01:25:00.821 Detail, Node002, Notification: ValueChanged

sorry I can’t be of more help

Thanks for this @alltherage
So in the end I removed the sensor from the door, played with it a bit (and everything worked) and then remounted it to the door frame, and it all seems to work fine now? I don’t know if it was misaligned (hard to see how though)? Either way, thanks for the reply, you inspired me to try further and get it working!

ah I’m glad! :slight_smile:

Guys I have spent literally hours and hours trying to get my Aeotec Recessed Door Sensors to work to no avail. Finally stumbled upon this post via a link from another post and now all is working perfectly!

Thank you so much! :grinning:

I’m having the same exact problem as you mentioned but I can’t seem to get this to work. I’ve tried everything mentioned here … the sensor won’t get out of sleep mode.

Hi in the end the issue was that I wasn’t having success in changing my sensor to a binary one because my sensor was always asleep when I was trying to implement the change.

I woke the sensor by holding the button on it for 6 seconds, then changed it to binary immediately afterwards and this time it stuck! Basically you need to wake the device before doing anything to it.

Hope this helps!

I was messing with this for the last 6 hours and between a few threads I was able to get the sensor into a mode that reported many variables rather than one sensor. I think I pressed the tiny button for like 20 seconds, then restarted HA. I also tried setting 121 to 4, or 8. Neither of those worked. Set parameter 121 to 16. With that, the “binary_sensor.aeotec_recessed_door_sensor_gen5_sensor” went from always on to changing with the magnet. Then I could get that info into an if/then/else setup in the configuration.yaml so I could make clean sense of the sensor in Lovelace. Ask if you’ve got questions, but 16 is the answer I found somewhere kind of unrelated. Second post by the taco.

Hi, I’m not sure if this is the place to ask. I have a Z-Wave, mulitsensor. I can see the ‘door sensor’ (I’m using it for a window) trigger for open/close. When it’s open it returns 22, closed returns 23. Can I set it so it displays “Open” and “Closed” instead. Is that something I do on the front end or is part of Z-Wave?

Thanks,