Can't get Seven Segments (SSOCR) to work

Hi all,
I’m struggling with Seven Segments to perform image recognition even on a static file. I’ve tried from the UI and from the command line on HA OS. I’ve gone through the main guide and got the component show up in the UI but never got any values despite trying with various files.
Did some troubleshooting as per to try to display the processed images, but with no luck. The interim file is not created at all nor the values show up. Most likely the processing fails, so this got me thinking whether the SSOCR is implemented in Alpine at all?

Digging further, I’ve done manual SSOCR build+install on HA OS and it works from the command line just like it does in terminal on my other laptop (macbook). However, still not working in the UI and after the docker is built again, all changes are lost.

Anyone got the SSOCR working with HA OS or has any idea how to get it working? Or am I missing something?

My config just in case:

    - platform: template
          value_template: "{{ states('image_processing.sevensegment_ocr_seven_segments') }}"
          friendly_name: 'GigaJoule'
          unit_of_measurement: 'GJ'

#input file to be recognised
  - platform: local_file
    file_path: /config/www/images/img_2.jpg
    name: seven_segments

#interim file to verify recognition    
  - platform: local_file
    file_path: /config/www/images/img_2_processed.jpg
    name: ssocr_processed

  - platform: seven_segments
      - entity_id: camera.seven_segments    
    extra_arguments: remove_isolated erosion 3 -Dimg_2_processed.jpg

I had spaces at the end of the "- entity_id: camera.seven_segments "
Also, surprisingly it didn’t want to work when x,y, height, width was not specified.


Anyway, maybe the above and below will be of help to anyone. Working config:

  - platform: seven_segments
      - entity_id: camera.seven_segments
    threshold: 30
    x_position: 0
    y_position: 0
    height: 279
    width: 501
    extra_arguments: 'remove_isolated erosion 3 -Dimg_2_processed.jpg'

Thank you for your post. I too was leaving those fields out and did not know how to debug.