Can't get to onboarding

I’m trying to install hassos on my raspberry pi 4. It all seems to be working until the onboarding process. I keep getting an alert saying “something went wrong loading onboarding, try refreshing”. I’ve refreshed dozens of times, rebooted my pi, and I still can’t continue with onboarding. I even just tried clearing out my cache in cash that was the issue. I use rasperry pi imager to write Home Assistant 9.5 to my SD card then load it into the pi and let it do its magic. Any suggestions?

Are you using a wired connection? Sounds like it can’t connect to the internet at this point.

At first I was attempting to create that wifi connection file after flashing the SD card, so that was my first thought. Then I connected it to LAN. Same issue. I even just tried using Balena Etcher to flash the SD card in case something was wrong with RPi Imager. My next step is to see if I can flash 9.0 instead of 9.5. If that doesn’t work then I’ll try 8…ect. I still get the page that says Home Assistant is loading (may take 20 minutes)…then when it’s done, it redirects to onboarding but every time I get that javascript message saying something went wrong loading onboard, try refreshing. My PI is connected to the internet also. It’s listed in my routers connected devices. I just attached a screenshot of my error I keep getting

Strange issue. I would avoid Wifi anyway (no-one sensible runs a server over Wifi :slight_smile: )

I have a standard RPI4 4GB and it works perfectly using Balena Etcher.

Which browser are you using - I know Chrome and FF work well, but I would avoid Safari/Edge etc.

Only other thing to try is the IP address … i.e. 192.168.1.2:8123 (replace with your Pi IP)

Also (it looks like you are using Chrome from the screenshot) press F12 and check the console logs - might be a clue in there :slight_smile:

1 Like

It looks like it’s saying it’s blocked by CORS policy.

OK, try using the ip instead of homeassistant.local

1 Like

IP addr worked.

2 Likes

Glad I could assist.