Can't get Z-Wave control panel on HA configuration

Hi everyone, I’m running Home Assistant under Docker on a Synology 218+, and have a Z-Stick 5 plugged into the NAS.

I did everything on a clean install by following the instructions outlined here (as recommended by HA’s installation on Docker) Installing on a Synology Diskstation NAS – Phil Hawthorne, and included

  usb_path: /dev/ttyACM0

in my configuration.yaml

Everything went smoothly with no errors, and I can access the HA web interface. However, there is no Z-Wave control panel under Configuration.

Did I miss a step or something? Totally at a loss here as I haven’t been able to find any other topics that encountered the same issue.

Would really appreciate some help here, thanks in advance!

Any help here? I’m really quite new to this so I’d be really thankful if someone could point me in the right direction… Thanks :slight_smile:

Have you checked the logs for errors relating to zwave?

That’s the Logbook option on the sidebar right?

There are no Z-Wave related errors there, only some entries about Home Assistant starting and restarting, and the occasional Sonos play/pause logs from my speakers (which it seems to have detected automatically).

Not sure - my logbook on the side doesn’t do anything so not sure what it shows… I go look at the logfiles directly. Try that first?

My logbook finally loaded. All that is is a log of events in HASS. It’s not the actual application logs (which is what you need to go look at).

Try the ‘I’ in Developer Tools on the left. I think that shows you errors from your application logs.

Is /dev/ttyACM0 the right usb controller path for your install? In the Z-wave docs there is a section about finding the correct usb path. Perhaps that is of help to you?

Thanks Soul! I’ve checked through the logs and there haven’t been any z-wave related errors. It’s like the Z-stick isn’t even there I guess

Yup, I’ve checked that the path is correct, using ls /dev/tty* in SSH.

I’m gonna reset my entire Synology and give the entire setup a try again. Maybe it’ll work this time… I’m not hopeful, but I haven’t got much to lose since it was a new setup to begin with.