Can't Install Eufy Security Integration


Okay … I found the log (I think it’s the right one) … I’ve set logging to debug … and I got a sh*tload of stuff I don’t understand. The log is huge, so instead of posting here, I’ve provided a link.

Home Assisstant Log (Eufy Integration Problems)

Any suggestions?


If this has been asked elsewhere, I apologize :slight_smile:

When trying to install the eufy integration, the configuration wizard starts, the little wheel spins … and some time much later I get the following:

Config flow could not be loaded: Unknown error

I don’t see anything in the logs - I’m not even sure which log to check.

I see the config files in:


I’ve retarted HA, checked configs, etc. HA core was just updated before trying this.

Home Assistant 2023.1.4
Supervisor 2022.12.1
Operating System 9.4
Frontend 20230110.0 - latest

I’m at a loss - don’t know where to look, nor how to begin to correct this.

Any help would be appreciated, muchly!


You have apparently enabled debug logging for whole home assistant, you just need to enable it for eufy_security component. This a huge file and very difficult to read.

Check integration readme page, it will direct you to set the logger

Okay … I’m an idiot … integration readme page? I’m not sure where that is. Is that the page that opens when you load the integration in HACS? If so - I don’t see anything in there that helps with logging …

Anyway - I removed the extra debug stuff and tried again. This log (home-assistant.log - Google Drive) shows that some files for eufy are not being downloaded – but most of them were, apparently.

I apologize for not being more knowledgeable about all of this, but I’m trying :slight_smile:

Thanks mucho!

Just read this page and embrace it.

Okay - that’s the same page that I was referring to … and have read (and followed) multiple times.

But - this time it’s different. I restored HA from a backup and started all over.

It appears to be working now. At least it’s working until I break something again.

Sorry to have bothered you.