Can't install eWeLink add-on - failed to install

issue: can’t install eWeLink addon via official repository
hw: raspberry pi 4 B
sw: home assistant OS image 6.5 64bit

in the past days i successfully added eWeLink official addon and it worked good.
then because I needed to change type of installation (from supervised on a Raspbian to a Home Assistant native image) and restored backup. It didn’t worked.
then tried to uninstall and install again:
got installation error

Failed to install add-on
The command '/bin/sh -c yarn --production' returned a non-zero code: 1

Sure I messed up something i started again with a fresh install.

added repository
selected eWeLink addon

again same error.
so started thinking it’s something else as installation is superfresh.

maybe related to 64bit version?

edit: tried another fresh install of 32bit image, no change. Seems an issue on specific version of eWeLink trying to install (1.2.2)

1 Like

Same problem here. Home Assistant Blue

Same problem for me also.

Same issue here.

It seems here is the solution: eWeLink Smart Home 1.2.2 upgrade failing - #9 by Platorello

after multiple tries and fails it got installed. now working flawlessly.
done backup :smiley: