Can't install from Hass.io Add-on Store

Tags: #<Tag:0x00007f3f1a2d0400> #<Tag:0x00007f3f1a2d01a8> #<Tag:0x00007f3f1a4fff00>

After a fresh install of HassOS 3.3 on a Raspberry Pi 4 I’m unable to install add-ons from the Hass.io Add-on Store:

When I click “Install” anyway on an add-on and check the Hass.io logs I see this error (thrown here):

ERROR (MainThread) [hassio.addons] Add-on core_samba not supported on that platform

This seems to be either the fact I’m running pre-release/beta versions of HassOS/HA, or a DNS issue.

I have a dedicated Pi with a static IP running Pi-hole and from my reading other people have had this issue with this setup. I’ve now set a static IP on the Pi running Hass.io (rather than a DHCP lease) and specified the DNS server running on the Pi-hole but this hasn’t fixed the problem, any ideas?

Exactly the same issue was just raised on discord: https://discordapp.com/channels/330944238910963714/330990055533576204

Addon devs are aware of the problem.

Thanks, this has been fixed (#434).

Any help would be appreciated … I’ve just installed HASSIO on proxmox all up and running fine but cant install anything from the Add On Store… error :-

19-07-20 10:12:11 INFO (MainThread) [hassio.core] Hass.io is up and running
19-07-20 10:12:23 INFO (SyncWorker_6) [hassio.docker.interface] Pull image homeassistant/amd64-addon-ssh tag 6.0.
19-07-20 10:12:23 ERROR (SyncWorker_6) [hassio.docker.interface] Can’t install homeassistant/amd64-addon-ssh:6.0 -> 500 Server Error: Internal Server Error (“Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:44808->[::1]:53: read: connection refused”).

|System|HassOS 2.12|
Supervisor 170