Can't install from USB on NUC?

any particular reason? This would allow you to use the NUC for other things as well.

I am the same as n0ir: With native install, and a couple of components, I can quite easily max out resources on my i7 16GB RAM NUC, I don’t really want to add additional management layers/OS that needs updating etc when I can do pretty much everything I would want to do from within Hassio + available addons…

Perhaps maxing it out is a sign that it’s not an OS optimized for your hardware at all. I run Alpine Linux on my NUC with a bunch of containers and don’t even come close to maxing out an i3 + 8gb RAM.

I max out my 8 core xeon ubuntu as well with the same docker containers… just try adding a couple of h.266 cameras to a setup and see what that does to your setup…

I have 4 h265 cameras connected to HA, and my CPU is next to nothing

CPU only ever gets hit by HA and Syncthing.

fair enough, I am however am using 3rd party applications (Like Zoneminder and motion) as gateway for storage and motion detection as I want the 3rd party applications to do what they were built for… HA not necessrily a NVR

Gotcha. I don’t use HA as an NVR either. The cameras all record to their own datasets on my NAS over NFS. I don’t have a need for an NVR.

Motion detection is built into my cameras and presented as binary sensors in HA.

yes, that is the most optimal way… but my camera’s are spread between South Africa and Jersey and I have close on 30 of them, so this is why I like a nice clean ui where I can edit motion detection settings and the associated recordings all in one place and not have to do that manually on each camera… especially when I can’t get direct access to the physical camera at the drop of a hat… :slight_smile: I can then use HA to trigger the motion detection recording as well so I am not simply recording motion detection all the time…

incidentally, and tying this conversation back to the thread… this is also why I don’t want to have manage additional OS’s and hence the native NUC build for me thanks, but each to their own :slight_smile:


yes, I am doing a global documentary on what happens at an airbnb party (jokes)

This was working for me. I have used the second method.
I found your video on YouTube, that was very use full to me.
First I get a error, then I used the line with the sudo command. That worked for me.
Thanks for posting

I have tried first method but without success, it says no bootable device found…can you help me?

I thought I would update everyone on what I have found and how I have adapted my setup.

Over time, but more often than not recently, I found my NIC on my NUC becoming unresponsive. I thought it had something to do with the bios which I subsequently updated.

After much reading, I saw that this issue was not uncommon and the solution involved turning off sleep modes on the ethernet adapter, which I was not able to do via the bios on the NUC.

This then spurred me into looking at my old work laptop which had a broken screen but was still a beast of a box. I installed Proxmox on this and then migrated my instance of home assistance from the NUC onto Proxmox…

I have to say that the experience was rather painless. As an added benefit now, I am able to do LACP to the instance combining an additional usb to ethernet adapter. THIs is handy as I have roughly 20 odd camera’s connected to my Home Assistant and the performance increase has been very noticeable!

I am not sure where this leaves me with my NUC, I have loaded Windows onto it which now enables me to control the ethernet sleep mode… I will possibly look at loading Proxmox back onto it but now with HA on my laptop on Proxmox, I have no real driver to move back to the NUC…

I hope this may helps some of you on deciding on which route to go…

What you said is very reasonable. My situation is the same as that of the landlord

I was able to get HA OS running on an Intel NUC DE3815TYKE by putting the OS directly on a SATA SSD that I put in the NUC.

I’ve tried other approaches as well, but I have not been succesfull yet as I did not find any image working on the system.

I think these approaches work one I can find a working image:

  • Install an OS on the SSD (other than HA OS), then install HASS on the internal memory by flashing it from the OS on the SSD.
    The OS I tried to install on the NUC is pc-dawson-xenial-amd64-m4-20180507-32.iso, but it gets stuck on my NUC:
    • I’ve put the ISO on a USB stick, it does not boot properly,
    • I tried installing on a SATA drive through VirtualBox, but I did not succeed.
      Next thing that I might try is to insert the SSD into another PC, and try to install system from the USB on a PC. Then run the SSD on the NUC.
  • Install HASS on the SSD (under windows), the clone from the SSD to the internal memory.
    However, I was unable to start clonezilla.

My issues might only be related to the old NUC type I have, you may have more success with such methods on your NUC.

I am not persisting on installing the OS on internal flash for the moment as I have issues with using a Zigbee USB stick on this system.

HA OS works fine from the SSD other than that USB limitation - I’ve added HACS and enabled the SSH+Terminal functionnality.

I managed to fix my USB issue, so I went further and finally get “stuck” because of the eMMC being too small (4Gbytes = 3.8GB).

If you have enough memory on the eMMC, then the method I followed may succeed:

  • Install Ubuntu 16.04 desktop on a SATA drive (either on the NUC or on another x86 machine);
  • Start Ubuntu 16.04 on the NUC (use F10 to go to the boot menu if needed). Then following the instructions on Generic x86-64 - Home Assistant - those instructions are mainly to get Baluna Etcher, drop the Home Assistant image url there, select and flash the target.

Personally I’ll have to go with either an iSSCI target on my NAS or an internal SATA disk and install HA OS directly on it. The latter already worked during my tests, but I want to redo it on a cheaper disk and recover my previous installation.

AMAZING! In my case I need hassio OS to use serial port, I booted from a Ubuntu LiveCD and once gui was up I jammed in the usb with a copy of the img.xz file on it and it automounted and popped up. I right clicked the image file and it gave me an option to open with imager and restored it directed to the m.2 SSD. When I restarted the machine it booted right up!