Can't install Hassio RP3


I’m really struggling to get Hassio up and running.
I’ve flashed a new nice sdcard with the hassio image corresponding to the rpi3 hardware I’m using.

No matter what I do, it seems Hassio never gets online, I cannot reach IP:8123.
I can verify that my RP has connected to my local network by running nmap or checking my ip leases in my router. I’ve also tried using a usb to supply network config and I’ve tried without. I have tested wireless and I’ve tested static ips over ethernet cable. I’ve also waited between 30 min and one whole night. I’ve also swapped the pie out for another rp3 i’m not using, same result. When I hook a hdmi cable up to my TV I can see it’s basically repeating the same pattern, IPV6 link not ready (no issues, not running ipv6) and some other mumbo jumbo…

From what I can understand, the network card on the pie gets an IP without problem but the virtual adapter used for the docker container does not. Hence, the website at 8123 is not available (because it cannot update)…

How do I proceed?


Probably bad advice, but I would install Dietpi, and then install hassio this way :

My hassio’s are installed this way

Hi francisp!

I came from a previous installation of Hassbian but thought coming over to hassio would be more straight forward, but so far… it’s just looping doing not what I want.

Why are you recommending installing and running it manually? Is the hassio image known to cause hard to diagnose issues?

Thanks a lot!

I use dietpi because it allows me boot from the sd, but have the rootfs on an external device, so preventing sd card corruption.

Are you sure you have the right image when flashing the SD card for the pi3?

32 or 64 bit?

I’ve tried both images, they fail equally bad :frowning:

Can you hook a monitor and keyboard up to the pi to see what is going on?

Hello all,

Case closed. I reflashed and reflashed and…reflashed, eventually the damned virtual adapter got an ip… holy hell. So much for quick and easy.