Can't install homeassistant-supervised.deb - "Repository is broken"

Hi all! I have a basic Debian 11 home assistant server set up running supervised. It’s been running pretty well for about a year and half, but something happened in a recent update, and the supervisor stopped working. I mostly ignored it, but after a recent update, now everything has stopped wroking. I tried to basically back up through the install process, remove os-agent and homeassistant-supervised, and deleted all the docker images (and updated that). Then reinstall everything. But now when I tried to install homeassistant-supervised.deb, I get this error.

Please help!

The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
After this operation, 0 B of additional disk space will be used.
Get:1 /home/kevin/homeassistant-supervised.deb homeassistant-supervised all 1.4.3 [6,456 B]
Preconfiguring packages ...                   
Selecting previously unselected package homeassistant-supervised.
(Reading database ... 332582 files and directories currently installed.)
Preparing to unpack .../homeassistant-supervised.deb ...
[warn] If you want more control over your own system, run
[warn] Home Assistant as a VM or run Home Assistant Core
[warn] via a Docker container.
Adding 'diversion of /etc/NetworkManager/NetworkManager.conf to /etc/NetworkManager/NetworkManager.conf.real by homeassistant-supervised'
Adding 'diversion of /etc/NetworkManager/system-connections/default to /etc/NetworkManager/system-connections/default.real by homeassistant-supervised'
Adding 'diversion of /etc/docker/daemon.json to /etc/docker/daemon.json.real by homeassistant-supervised'
Adding 'diversion of /etc/network/interfaces to /etc/network/interfaces.real by homeassistant-supervised'
Unpacking homeassistant-supervised (1.4.3) ...
Setting up homeassistant-supervised (1.4.3) ...
[info] Restarting NetworkManager
[info] Set up systemd-journal-gatewayd socket file
[info] Enable systemd-journal-gatewayd
dpkg: error processing package homeassistant-supervised (--configure):
 installed homeassistant-supervised package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
W: Repository is broken: homeassistant-supervised:amd64 (= 1.4.3) has no Size information
E: Sub-process /usr/bin/dpkg returned an error code (1)

(I know I should probably use OS, but my server machine is just an old laptop - so old, it cannot support virtual machines! That’s the main reason I’m running supervised directly on metal)

1 Like

I think this was covered by this release note:

And I think the “Repository is broken” message is not important.

Also I think there was a required python update recently too. I don’t run a (shudder) supervised install. So I’m not really sure when it was.

What do you mean? Anything x86 can run VM’s since the Pentium age, basically :wink:

But the bottom-line for me stills is: If you can manage a supervised install, you actually don’t need it and you should use a plain container installation :wink:

That would be for Core, I guess. Python is embedded in the HA image.

1 Like

There will be a python update to 3.11 in the next release for June, which will break things on some systems running on bare metal.
I do not think Debian 11 have a python 3.11 apt package yet, so it will have to be compiled.

Edit: python 3.10 will first be deprecated in August.

Once again, nothing to do with “bare metal” (besides maybe some adventurers, we all use HA on a “bare metal”, i.e. not in AWS or Azure but on a physical machine).
It will (maybe) be a problem for the roughly 3% HA users using the “Core” installation method, i.e. installing the HA python packages and dependencies with pip. The others use the HA docker images, which has python baked in.

HA is tricky enough without adding accidental FUD :wink:

Bare metal is a reference to running on the hardware directly.
If you run docker, proxmox, LXC, Hyper-V, VirtualBox or some other hypervisor, then you do not run it on the bare metal.
It does really not matter if the hypervisor is placed at Amazon, Microsoft or in your own home.

But you are correct that it does probably not apply here, since it is a supervised installation and that means docker.

By that definition, a HA Core running in a Linux VM is not “bare metal”, but it will definitely be hit by the python bump :wink:

True, it is not bare metal, but will be hit. :slight_smile:

Debian 12 will be released on June 10th 2023 anyway. And according to ADR-0014, when a new major version of Debian is released, the previous major version is dropped, with a deprecation time of 4 months.

Good to know!
I will start planning an update of my systems then.:smiley:

I’m exactly on the same page… have you find any workarounds to reinstall home assistant supervised?
I’m currently here:

W: Repository is broken: homeassistant-supervised:amd64 (= 1.4.3) has no Size information
E: Sub-process /usr/bin/dpkg returned an error code (1)

The workaround was to remove the package, download the previous release (1.4.1) and install that instead:

sudo apt remove -y homeassistant-supervised
wget -O homeassistant-supervised-1.4.1.deb
sudo apt install -y ./homeassistant-supervised-1.4.1.deb
1 Like

It’s a hobbled cheap laptop from more than a decade ago that I stuffed an SSD in. Runs Home Assistant great! But one of the compromises the “Pentium” branded chip has is that it has no support for Intel VT. It’s a Pentium(R) Dual-Core CPU T4300, checkout the spec sheet - awful! Now that supply chains are finally clearing up I’ll probably grab a cheap Raspberry Pi 4 or Odroid C4, or something similar.

FWIW, VT-x is a (quite) recent technology facilitating virtualization.
I’m pretty sure your laptop can run VMs a VM in virtualbox (although quite surely 32bits only).